command not found: CONDA_SUBDIR

I have a problem about qiime2 install.
My environment is Macbook Air (M1).

I have checked past questions in this forum and found that it is probably an issue with Apple M1 chip. (Install QIIME2 on Macbook Pro 2021 with apple M1 Chip)
I installed miniforge3(
I set the terminal app to run under rosetta mode.
But, I have failed to install qiime2 as follows.

% CONDA_SUBDIR = osx-64 conda env create -n qiime2-2022.2 --file qiime2-2022.2-py38-osx-conda.yml
zsh: command not found: CONDA_SUBDIR

What is wrong?
Looking forward to your reply!

Hello @kurh-08,

Welcome to the forums! :qiime2:

Double check that you are running exactly what is shown in the examples

In your version, I notice spaces around the = equals sign = and I wonder if that's causing problems.

Thank you for your help.
I tried
% CONDA_SUBDIR=osx-64 conda env create -n qiime2-2022.2 --file qiime2-2022.2-py38-osx-conda.yml
But, I got different error as follows.
SpecNotFound: Invalid name, try the format: user/package

What should I try next?
Sorry for bother you.

We are on the right track!

Looks like conda has been updated sense that tutorial was written.

Based on this post, it now
conda create
instead of
conda env create
as shown in that tutorial.

Thank you for your reply! @colinbrislawn

Finally, I can create environment! Thanks to you :smile:

When I try
CONDA_SUBDIR=osx-64 conda create -n qiime2-2022.2 --file qiime2-2022.2-py38-osx-conda.yml
I get error as follows.
CondaValueError: could not parse '- qiime2/label/r2022.2' in: qiime2-2022.2-py38-osx-conda.yml

conda env create -n qiime2-2022.2 --file qiime2-2022.2-py38-osx-conda.yml
this script worked well.
Finally, in my environment, the problem seems to have been solved by installing miniforge3 and changing to Rosetta mode.

Thanks a lot!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.