Checking the content of qzv files


I'm working on visualization for the covariance matrix in my plugin. I've seen a couple of implemented heatmap visualizations in existing qiime2 plugins, but I use my own semantic type ("PairwiseFeatureData") specific to the problem I solve and that made me re-create the wheel.

I was following this thread by @Nicholas_Bokulich, and I found this example very helpful, thanks! So, I made this action working:

!qiime gglasso heatmap \
    --i-covariance-matrix example/data/88soils_covariance.qza \
    --p-normalize True \
    --o-visualization example/data/88soils_heatmap.qzv

and producing me .qzv file but I experience the problem with rendering HTML, anything I write down in index.html appears except the figure.

I guess there is no figure stored in the produced .qzv file, how one can check if that is true?
Now, I simply uploading it to

Or maybe I save the figure in the wrong directory?
Since I work in Docker container and should I refer to the figure differently in index.html? Now, I follow the example above.
Thank you!

There are several options you can to try to check the content of existing qzv file.

  1. Using export plugin in Qiime2:
qiime tools export \
    --input-path some.qzv\
    --output-path some_dir/
  1. Unzip it as a zip file via terminal

  2. In ubuntu, one can just double click on the file to open is as an archive.


thank you, Timur!
good news, I've exported the files and the plots are there
then the environment does not play a role since I'm rendering HTML on, any ideas what's the problem?

Hi @Oleg ,
As a quick sanity check, you could try a different browser.

We have seen some browser-specific issues when viewing very large images. You could also attempt to create a small covariance matrix just to text if loading large images is the problem.

1 Like

thank you!
found the bug and fixed it, now it works :ok_hand: