Can't filter out technical replicates from dataset using qiime feature-table filter-samples

Hello!

In my dataset I have 47 samples, two of which are technical replicates that were performed to understand if the these would in fact group outside of its expected group or not and/or if the original samples were mislabeled along the way.

By looking at the technical replicate data, it was concluded that the labels for those two originals samples were switched, hence these were grouping with the wrong category.

Now, I wanted to remove these technical replicates using the filter-samples, and I even read a topic on this about how to use the --p-where SQLite clause, but I always get retrieved an error like

Plugin error from feature-table:

  Selection of IDs failed with query:
   SELECT "#SampleID" FROM metadata WHERE 23SF1B GROUP BY "#SampleID" ORDER BY "#SampleID";

  If one of the metadata column names specified in the `where` statement is on this list of reserved keywords (http://www.sqlite.org/lang_keywords.html), please ensure it is quoted appropriately in the `where` statement.

Debug info has been saved to /tmp/qiime2-q2cli-err-qxbelw7o.log

This error was obtained without using the WHERE parameter though. Nevertheless, I've tried a few different commands to specifically filter out the data from these two replicates... can anyone shed a light to which would be the best way? I've read something about creating an extra collumn in the metadata but I didn't fully understand what they meant by that.

Any help will be appreciated :slight_smile:

Hi @sasha.lucmac,
Can you rerun the command you have tried using the --verbose flag and post the command and full corresponding error here. If possible can you also share the files you are using to filter with? I am hopeful that we can figure out what is happening here.
--Hannah

1 Like

Hello!

I encountered the same error a while ago several times and as far as I remember the issue was in:

Once renaming values in the metadata file solved the issue. Another time the issue was that I declared filtering formula in jupyter and provided it as $filtering to the plugin but in fact it should be "$filtering".

Best,

1 Like