Cannot import FASTA file for Sanger sequences

I have successfully imported these types of data in the past using this command, but when I try to do that now, I get the error

There was a problem importing Hines_SeqData_Final.fasta:
Hines_SeqData_Final.fasta is not a(n) QIIME1DemuxFormat file

I did clean up/simplify my sequences names before trying to import this time. Would that cause this error, or is this an issue stemming from the new q2-2019.1 release?

Here is a sample of some of my sequences:


Any help is much appreciated.

Hi @jhines1! The QIIME1DemuxFormat is defined here:

Looks like your label lines need to be updated to match that spec. Are the .49 and .50 sequences IDs? If so, you can just replace the periods . with spaces.

EDIT: Replacing the ‘.’ with ‘_’ worked. Thanks!!

No need to apologize - I confused myself re-reading that spec. You should actually use an underscore _, not a space (I think).

It worked. Thanks!! Glad it was that simple! :grin:

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.