Can qiiime2-2018.11 process 2018.8 output files

Good day!

One of my deblur output files was generated using 2018.11. My other deblur output files were generated using 2018.8. When I ran the below mentioned command line
qiime feature-table merge
–i-tables acer-august-rep-seqs-table.qza
–i-tables acermay2-rep-seqs-table.qza
–i-tables acermay-rep-seqs-table.qza
–i-tables acer-june-rep-seqs-table.qza
–i-tables acerjuly-rep-seqs-table.qza
–o-merged-table acer-y3-rep-seqs-table.qza

I received this error
ValueError: acer-june-rep-seqs-table.qza was created by ‘QIIME 2018.11.0’. The currently installed framework cannot interpret archive version ‘5’.

My question is if I update the 2018.8 version to 2018.11, will I still be able to merge my files, and run the additional downstream command lines?

Cheers
NYF

Hey there @nyflo!

We updated the archive structure in 2018.11, which explains this error — QIIME 2 2018.8 is not aware of those changes.

Yep! QIIME 2 is backwards-compatible — files made in older versions of QIIME 2 can always be read by the framework. The error you ran into above has to do with forwards-compatibility, which we don’t guarantee (how can we? how can we teach an old version of QIIME 2 about a new version of QIIME 2?)

Thanks! :t_rex:

PS - no need to “update” - you can install 2018.11 side-by-side with 2018.8 in separate conda envs

Thanks for breaking it down for me. Everything is running smoothly. No errors

Cheers!

1 Like