Can not import fastq data, not even tutorial's

I am a new user in qiime2. After i complete moving pictures tutorial i tried to analyse my own data but i could not import fastq files. I read the "importing data" tutorial and tried to do all of them after failure in my first attempt with my own data. There was no problem with EMP protocol but Casava 1.8 single-end demultiplexed fastq protocol does not worked with error:
(qiime2-2018.8) qiime2@qiime2core2018-8:~/import$ unzip -q
(qiime2-2018.8) qiime2@qiime2core2018-8:~/import$ qiime tools import \

--type 'SampleData[SequencesWithQuality]'
--input-path se-33-manifest
--output-path single-end-demux.qza
--source-format SingleEndFastqManifestPhred33
Error: no such option: --source-format

I did everything as implicated in tutorial, moreover, i try to make some modifications regarding to previous comments of the forum users but no luck either. My own data came as two fastq reads as paired end but there is no barcode file so i choose to do with casava 1.8 paired end method but i get the same error. I would be appreciated if you can help me.

Hey there @ibrahim!

It looks like you are running QIIME 2 2018.8, but using the tutorial or a guide from an older version of QIIME 2. That flag --source-format was renamed to --input-format --- see the changelog for more details:

In the meantime, use the version of the docs that matches the version of QIIME 2 you are using and you should be all set! :qiime2: :t_rex:

Thank you thermokarst, you were right. It works :slight_smile: Have a great day.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.