Breakaway won't install on cluster, won't run on PC

I am running Qiime2-2019.10 on conda via our university's cluster. I am trying to install breakaway following the instructions from this tutorial: Q2-breakaway: Community Tutorial

When I try to run the command "pip install git+https://github.com/statdivlab/q2-breakaway.git" I get the following error:

Collecting git+https://github.com/statdivlab/q2-breakaway.git
Cloning GitHub - statdivlab/q2-breakaway: QIIME2 plug-in for breakaway to /tmp/pip-req-build-u35jj764
Running command git clone -q GitHub - statdivlab/q2-breakaway: QIIME2 plug-in for breakaway /tmp/pip-req-build-u35jj764
ERROR: Command errored out with exit status 1:
command: /home/sthansen/miniconda/envs/qiime2-2019.10/bin/python -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-req-build-u35jj764/setup.py'"'"'; file='"'"'/tmp/pip-req-build-u35jj764/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(file);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, file, '"'"'exec'"'"'))' egg_info --egg-base /tmp/pip-req-build-u35jj764/pip-egg-info
cwd: /tmp/pip-req-build-u35jj764/
Complete output (42 lines):
usage: git rev-list [OPTION] ... [ -- paths... ]
limiting output:
--max-count=nr
--max-age=epoch
--min-age=epoch
--sparse
--no-merges
--remove-empty
--all
--branches
--tags
--remotes
--stdin
--quiet
ordering output:
--topo-order
--date-order
--reverse
formatting output:
--parents
--children
--objects | --objects-edge
--unpacked
--header | --pretty
--abbrev=nr | --no-abbrev
--abbrev-commit
--left-right
special purpose:
--bisect
--bisect-vars
--bisect-all
Traceback (most recent call last):
File "", line 1, in
File "/tmp/pip-req-build-u35jj764/setup.py", line 16, in
version=versioneer.get_version(),
File "/tmp/pip-req-build-u35jj764/versioneer.py", line 1480, in get_version
return get_versions()["version"]
File "/tmp/pip-req-build-u35jj764/versioneer.py", line 1453, in get_versions
pieces = from_vcs_f(cfg.tag_prefix, root, verbose)
File "/tmp/pip-req-build-u35jj764/versioneer.py", line 1110, in git_pieces_from_vcs
pieces["distance"] = int(count_out) # total number of commits
TypeError: int() argument must be a string, a bytes-like object or a number, not 'NoneType'
----------------------------------------
ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.

I was able to successfully install breakaway on my own laptop. When I tried to run my first command however, I got this error (including some of the verbose info before error in case it's helpful):

You have tibble installed!

You have magrittr installed!

Thank god! devtools is already available

Great! phyloseq is already available

Attempting to make phyloseq object...

[1] "otu_table"
attr(,"package")
[1] "phyloseq"
Downloading GitHub repo adw96/[email protected]
sh: 1: /usr/bin/gzip: not found
sh: 1: /bin/gtar: not found
sh: 1: /usr/bin/gzip: not found
sh: 1: /bin/gtar: not found
Error: Failed to install 'breakaway' from GitHub:
error in running command
In addition: Warning messages:
1: In system(paste(TAR, "--version >", tf, "2>&1")) :
error in running command
2: In system(cmd) : error in running command
3: In utils::untar(tarfile, ...) :
‘/usr/bin/gzip -dc '/tmp/RtmppKmxyD/file508a97d47a.tar.gz' | /bin/gtar -xf '-' -C '/tmp/RtmppKmxyD/remotes508b211edd'’ returned error code 127
4: In system(paste(TAR, "--version >", tf, "2>&1")) :
error in running command
Execution halted
Traceback (most recent call last):
File "/miniconda3/envs/qiime2-2019.10/lib/python3.6/site-packages/q2cli/commands.py", line 328, in call
results = action(**arguments)
File "</miniconda3/envs/qiime2-2019.10/lib/python3.6/site-packages/decorator.py:decorator-gen-487>", line 2, in alpha
File "/miniconda3/envs/qiime2-2019.10/lib/python3.6/site-packages/qiime2/sdk/action.py", line 240, in bound_callable
output_types, provenance)
File "/miniconda3/envs/qiime2-2019.10/lib/python3.6/site-packages/qiime2/sdk/action.py", line 383, in callable_executor
output_views = self._callable(**view_args)
File "/miniconda3/envs/qiime2-2019.10/lib/python3.6/site-packages/q2_breakaway/_alphas.py", line 54, in alpha
run_commands([cmd])
File "/miniconda3/envs/qiime2-2019.10/lib/python3.6/site-packages/q2_breakaway/_alphas.py", line 37, in run_commands
subprocess.run(cmd, check=True)
File "/miniconda3/envs/qiime2-2019.10/lib/python3.6/subprocess.py", line 418, in run
output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command '['run_new_richness.R', '/tmp/tmpfcppp6f7/table.tsv', '/tmp/q2-AlphaDiversityFormat-t_fyoyf6']' returned non-zero exit status 1.

Plugin error from breakaway:

Command '['run_new_richness.R', '/tmp/tmpfcppp6f7/table.tsv', '/tmp/q2-AlphaDiversityFormat-t_fyoyf6']' returned non-zero exit status 1.

See above for debug info.

Any help would be appreciated!

1 Like

Hi @sthansen! Thanks for the post.
For the cluster installation would you be able to give me the git version that’s on your cluster? You can retrieve that with
git --version

For your local PC, it looks like breakaway wasn’t installing on your machine because of a devtools issue. Are you using a Linux machine perchance?

If so, could you try these set of installation commands and see if you’re able to run your data?

source activate qiime2-2019.10

pip install git+https://github.com/statdivlab/q2-breakaway.git

R -e 'Sys.setenv(TAR = "/bin/tar"); library(devtools); devtools::install_github("adw96/breakaway")'

qiime dev refresh-cache

Let me know how you go!

Pauline

2 Likes

Hi Pauline,

Thank you for trying to help! The git version is git version 1.7.1 on the cluster.

The suggestion for the installation instructions on my laptop worked! Thank you!

-Shae

2 Likes

Okay! So, I think that the issue with it not working on the cluster might be because your git version is older. Can you try updating it and seeing if the installation will run?

I believe you can try one of these approaches to update git depending on your operating system: https://confluence.atlassian.com/bitbucketserver/installing-and-upgrading-git-776640906.html

Let me know how that works!

Unfortunately I cannot use sudo on the cluster, and I don’t know how to update git otherwise. I may just need to run breakaway local for now.

Thank you for your help in getting it to run on my machine!

1 Like

You can install software from conda without sudo access! And git is on conda.
Everything is on conda! :snake:

conda install -c anaconda git
https://anaconda.org/anaconda/git

2 Likes

I tried updating git via conda, and now when I try to run the breakaway install it gives me this error:

(qiime2-2019.10) -bash-4.1$ pip install git+https://github.com/statdivlab/q2-breakaway.git
Collecting git+https://github.com/statdivlab/q2-breakaway.git
Cloning https://github.com/statdivlab/q2-breakaway.git to /tmp/pip-req-build-8bhvarh2
Running command git clone -q https://github.com/statdivlab/q2-breakaway.git /tmp/pip-req-build-8bhvarh2
git: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory
ERROR: Command errored out with exit status 127: git clone -q https://github.com/statdivlab/q2-breakaway.git /tmp/pip-req-build-8bhvarh2 Check the logs for full command output.

Hey @sthansen!

Looks like the installation of git didn’t work, it appears to be missing some dependencies. I don’t think you need git, though, you can just download the latest source from here:

https://github.com/statdivlab/q2-breakaway/archive/master.zip

So to stitch together with what @Pauline_Trinh wrote above:

source activate qiime2-2019.10
wget https://github.com/statdivlab/q2-breakaway/archive/master.zip
pip install master.zip
R -e 'Sys.setenv(TAR = "/bin/tar"); library(devtools); devtools::install_github("adw96/breakaway")' 
qiime dev refresh-cache

Hope that helps!

hello, @Pauline_Trinh!

I'm experiencing a similar issue with the installation of breakaway, may I ask you if the plugin is still maintained?

I was following the instructions given on Github, and qiime2 tells me that the plugin is installed when I try

qiime breakaway --help

However, when I try to reproduce the standard example:

qiime breakaway alpha \
--i-table table-deblur.qza \
--o-alpha-diversity richness-better.qza

I face with an error, please, see the attached log file.
The problem seems to be with the dependencies, but I was not able to solve it, do you have something like requirements.txt - a list with all dependencies including the version?
I tried both Linux and macOS, and I use the latest q2 version 2022.2.
Thank you.
log.txt (23.1 KB)

Hi @Oleg! :wave:t3:

QIIMing in here (pun intended) because it looks like Pauline hasn't been active on the forum over the last couple of years. In looking at the Github repository, the latest commits there are from 4 years ago - so this plugin isn't being actively maintained at this time.

With regards to the log file you shared, you are exactly right - this is a dependency-related issue. You can take a look at all of the dependencies for this plugin under the recipe file within that repo (linked here).

If you are really keen on getting q2-breakaway to work, you could mess around with the dependencies installed in your environment (i.e. uninstalling/reinstalling specific deps with different versions to see if that fixes the error) - but with that being said, since this plugin isn't currently being maintained, there won't be any active support if you run into any issues such as this one, or have questions regarding the output.

Hope this helps!

Cheers :lizard:

3 Likes