"bash: qiime: command not found..." when conda env has qiime2 installed and is activated

I am receiving the following error when trying to run any qiime commend (eg: qiime --help):

bash: qiime: command not found...

My conda environment is activated and running "conda list" reveals that qiime2 is installed. I've tried uninstalling and reinstalling qiime2, creating fresh conda environments and installing various qiime2 versions into them, creating conda environments from yaml files accessible from various corners of the internet, and have attempted doing all of these things again after updating conda. Every attempt results in the same error. I've also tried doing this on two different college's HPCs that I have access to.

Here are some details about my software versions that may be relevant:
current qiime2 version: 2024.2.0 (I've also tried with 2023.7.0, 2024.2.0, and 2022.11.1)
current conda version: 24.3.0 (I've also tried with 23.3.1)

If I can provide any other information that will help you understand the problem, I'm happy to provide it. Thank you for your help!

Hello @airborne_manatee,

Can you activate your qiime2 environment and run echo $PATH, conda info, and conda list and post the output from each?

Sure thing!

echo $PATH outputs the following:


conda info outputs the following:

active environment : cT_qiime2
active env location : /home/gr104/software/miniforge3/envs/cT_qiime2
shell level : 1
user config file : /home/gr104/.condarc
populated config files : /home/gr104/software/miniforge3/.condarc
conda version : 24.3.0
conda-build version : not installed
python version : 3.10.14.final.0
solver : libmamba (default)
virtual packages : __archspec=1=sapphirerapids
base environment : /home/gr104/software/miniforge3 (writable)
conda av data dir : /home/gr104/software/miniforge3/etc/conda
conda av metadata url : None
channel URLs : conda-forge/linux-64
package cache : /home/gr104/software/miniforge3/pkgs
envs directories : /home/gr104/software/miniforge3/envs
platform : linux-64
user-agent : conda/24.3.0 requests/2.31.0 CPython/3.10.14 Linux/5.14.0-362.24.1.el9_3.x86_64 rocky/9.3 glibc/2.34 solver/libmamba conda-libmamba-solver/24.1.0 libmambapy/1.5.8
UID:GID : 3020:3001
netrc file : None
offline mode : False

conda list outputs the following:

packages in environment at /home/gr104/software/miniforge3/envs/cT_qiime2:

Name Version Build Channel
_libgcc_mutex 0.1 conda_forge conda-forge
_openmp_mutex 4.5 2_gnu conda-forge
appdirs 1.4.4 pyh9f0ad1d_0 conda-forge
atpublic 3.0.1 pyhd8ed1ab_0 conda-forge
bcrypt 4.1.2 py38h0cc4f7c_0 conda-forge
bibtexparser 1.4.1 pyhd8ed1ab_0 conda-forge
brotli-python 1.1.0 py38h17151c0_1 conda-forge
bzip2 1.0.8 hd590300_5 conda-forge
ca-certificates 2024.2.2 hbcca054_0 conda-forge
certifi 2024.2.2 pyhd8ed1ab_0 conda-forge
cffi 1.16.0 py38h6d47a40_0 conda-forge
charset-normalizer 3.3.2 pyhd8ed1ab_0 conda-forge
cryptography 42.0.7 py38h1407eca_0 conda-forge
decorator 4.4.2 py_0 conda-forge
dill 0.3.8 pyhd8ed1ab_0 conda-forge
flufl.lock 7.1 pyhd8ed1ab_0 conda-forge
globus-sdk 3.41.0 pyhd8ed1ab_0 conda-forge
icu 73.2 h59595ed_0 conda-forge
idna 3.7 pyhd8ed1ab_0 conda-forge
importlib_resources 6.4.0 pyhd8ed1ab_0 conda-forge
keyutils 1.6.1 h166bdaf_0 conda-forge
krb5 1.21.2 h659d440_0 conda-forge
ld_impl_linux-64 2.40 h55db66e_0 conda-forge
libblas 3.9.0 22_linux64_openblas conda-forge
libcblas 3.9.0 22_linux64_openblas conda-forge
libedit 3.1.20191231 he28a2e2_2 conda-forge
libffi 3.4.2 h7f98852_5 conda-forge
libgcc-ng 13.2.0 h77fa898_7 conda-forge
libgfortran-ng 13.2.0 h69a702a_7 conda-forge
libgfortran5 13.2.0 hca663fb_7 conda-forge
libgomp 13.2.0 h77fa898_7 conda-forge
libiconv 1.17 hd590300_2 conda-forge
liblapack 3.9.0 22_linux64_openblas conda-forge
libnsl 2.0.1 hd590300_0 conda-forge
libopenblas 0.3.27 pthreads_h413a1c8_0 conda-forge
libsodium 1.0.18 h36c2ea0_1 conda-forge
libsqlite 3.45.3 h2797004_0 conda-forge
libstdcxx-ng 13.2.0 hc0a3c3a_7 conda-forge
libuuid 2.38.1 h0b41bf4_0 conda-forge
libxcrypt 4.4.36 hd590300_1 conda-forge
libxml2 2.12.7 hc051c1a_0 conda-forge
libxslt 1.1.39 h76b75d6_0 conda-forge
libzlib 1.2.13 hd590300_5 conda-forge
lxml 5.2.2 py38h81c7c4b_0 conda-forge
ncurses 6.5 h59595ed_0 conda-forge
networkx 3.1 pyhd8ed1ab_0 conda-forge
numpy 1.24.4 py38h59b608b_0 conda-forge
openssl 3.3.0 hd590300_0 conda-forge
pandas 1.5.3 py38hdc8b05c_1 conda-forge
paramiko 3.4.0 pyhd8ed1ab_0 conda-forge
parsl 2023.12.4 pyhd8ed1ab_0 conda-forge
pip 24.0 pyhd8ed1ab_0 conda-forge
psutil 5.9.8 py38h01eb140_0 conda-forge
pycparser 2.22 pyhd8ed1ab_0 conda-forge
pyjwt 2.8.0 pyhd8ed1ab_1 conda-forge
pynacl 1.5.0 py38h01eb140_3 conda-forge
pyparsing 3.1.2 pyhd8ed1ab_0 conda-forge
pysocks 1.7.1 pyha2e5f31_6 conda-forge
python 3.8.19 hd12c33a_0_cpython conda-forge
python-dateutil 2.9.0 pyhd8ed1ab_0 conda-forge
python_abi 3.8 4_cp38 conda-forge
pytz 2024.1 pyhd8ed1ab_0 conda-forge
pyyaml 6.0.1 py38h01eb140_1 conda-forge
pyzmq 26.0.3 py38ha44f8e3_0 conda-forge
qiime2 2024.2.0 py38h1da1538_0 qiime2
readline 8.2 h8228510_1 conda-forge
requests 2.31.0 pyhd8ed1ab_0 conda-forge
setproctitle 1.3.3 py38h01eb140_0 conda-forge
setuptools 69.5.1 pyhd8ed1ab_0 conda-forge
six 1.16.0 pyh6c4a22f_0 conda-forge
tblib 3.0.0 pyhd8ed1ab_0 conda-forge
tk 8.6.13 noxft_h4845f30_101 conda-forge
tomlkit 0.12.5 pyha770c72_0 conda-forge
typeguard 2.13.3 pyhd8ed1ab_0 conda-forge
typing-extensions 4.11.0 hd8ed1ab_0 conda-forge
typing_extensions 4.11.0 pyha770c72_0 conda-forge
tzlocal 2.1 pyh9f0ad1d_0 conda-forge
urllib3 2.2.1 pyhd8ed1ab_0 conda-forge
wheel 0.43.0 pyhd8ed1ab_1 conda-forge
xz 5.2.6 h166bdaf_0 conda-forge
yaml 0.2.5 h7f98852_2 conda-forge
zeromq 4.3.5 h75354e8_4 conda-forge
zipp 3.17.0 pyhd8ed1ab_0 conda-forge

Hello @airborne_manatee,

You have qiime2 installed but no other qiime2-related packages. Importantly, you don't have q2cli which is needed for qiime to work on your command line.

Do you want a more minimal installation of qiime than those recommended in the installation documentation? If so, then you can just install q2cli with

conda install q2cli -c https://packages.qiime2.org/qiime2/2024.2/tiny/released

If not, then just follow the linked-to instructions. Hope this helps.

That solved the issue. Thank you for your help!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.