Any way to control read length parameter filtering in vserach dereplicate?

Hi qiimers,
I want to cluster my short reads(really short ~18nts) by using vsearch open-reference. However,I need to convert my fastq file --> SampleData–>featureData. It is fine for the first conversion. When I use vsearch to get featureData from SampleData, I got the error that all of reads are removed. The command is this:
qiime vsearch dereplicate-sequences
–i-sequences test.qza
–o-dereplicated-table table-test.qza
–o-dereplicated-sequences rep-seqs-test.qza
–verbose

After checking the posts here and source codes of vsearch as well, I found that the reason of all of my reads were filtered out is due to the parameter set in vsearch ‘–minseqlength’ which is set to 32 as default. Unfortunately, I couldn’t find a way in qiime2 to twist this parameter (maybe I miss this). Anyone has suggestion to avoid this?

Also, if I try to use vsearch to dereplication, how could I convert the outputs there to .qza that I can move forward to the clustering in qiime2?

Thanks!

Dong

Hi @lindongdo!

I have opened a support ticket to keep track of this request, but at present there isn’t a good way to make this change yourself.

You could run the dereplication step outside of q2-vsearch. Once done, you would have to manually create the feature table and rep-seqs for import into QIIME 2, which involved a little bit of work.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.