Ancom output not generating

Qiime2 seems to have hung up when trying to generate the ancom file… can anyone see anything wrong with the code?

I first tried it with the original table, but got an error, so I tried the previous code to generate a composition table first; it seemed to have worked, but it hung for about an hour on this code without generating any output. I then just Ctrl + C to cancel.

This is kind of important for measuring differential abundance in my project.

Any help would be appreciated.

Thanks.

Hi @dvdharkin,

I think ANCOM is a fairly computationally expensive algorithm. It’s possible that it can take over an hour to run. Do you have reason to believe that it should complete in under an hour? I would suggest allowing to job to run for longer before canceling it unless you are absolutely sure that it shouldn’t take that long.

Aside, from that, in your screen shot, I notice what appears to be some rogue text: table co> on the second line after qiime composition ancom. That looks like a typo to me.

1 Like

Hi @andrewsanchez , Thank you. The rest of the codes only took a few minutes to generate output. This is why I thought that after an hour it wasn’t working.

Oh, this is my code :qiime composition ancom
–i-table comp-table.qza
–m-metadata-file first_sample_meta.tsv
–m-metadata-column cohort
–o-visualization ancom-cohort.qzv

I just think it wasn’t display properly on the window.

I’ll try again thanks.

1 Like

I was just wondering what kind of time it would take for a regular laptop running core i5 1.60ghz, 8gb ram @ 1330Mhz on Windows 10 to output the ancom results?

Hi @dvdharkin ,
Runtime for ancom, like many things, really depends on much more than hardware specs — it is really quite difficult to predict.

As @andrewsanchez already pointed out, ancom can be quite computationally intensive if you have many features and/or samples. Issues with runtime have been reported a lot on this forum, so you could search the archives for different ways to address this, e.g., the advice in this post still stands:

Other than that, the best system spec for using ancom is a bit of patience :man_shrugging:

Good luck!

1 Like

@Nicholas_Bokulich @andrewsanchez duly noted.

Yes, it did eventually run successfully and took a little over an hour.

Thank you for the help.

2 Likes