Alpha Diversity Table Empty With No Errors

(Stephanie Orchanian) #1

I’m trying to run alpha group significance using

qiime diversity alpha \
    --i-table filtered_table.qza  \
    --p-metric shannon \
    --o-alpha-diversity shannon_vector.qza
qiime diversity alpha-group-significance \
    --i-alpha-diversity shannon_vector.qza \
    --m-metadata-file q2_doty_metadata.txt \
    --o-visualization shannon_vector_alpha-sig

but I keep getting this error:

**Plugin error from diversity:**

**iteration over a 0-d array**

**Debug info has been saved to /var/folders/n8/0xt_lgk564l03t70txcj45xc0000gn/T/qiime2-q2cli-err-8jpt597y.log**

When I looked at my shannon table, it only has the sample names in it and no numbers in the 2nd column. But I’m not getting any errors when I run alpha diversity. Do you know how I can fix this?

filtered_table.qza (393.0 KB)
q2_doty_metadata.txt (2.6 MB)

0 Likes

(Mehrbod Estaki) #2

Hi @Stephanieorch,

What is the nature of your feature-table? I ask because when I visualized it, there were some funky looking things inside of it. First thing I noticed was that it looks like your feature-table is not a true frequency table but rather some sort of normalized or relative abundances?


The second thing is that either most of your samples have no counts or maybe they are very close to zero somehow that are rounded to zero?

And finally, in the feature table there seems to be only one feature?

I’m guessing some or all of this is causing the error.

2 Likes

(Stephanie Orchanian) #3

I’m using metabolomics data. It seems I filtered incorrectly! After I fixed the issue of losing most of my features, I’m still getting the error. Is alpha diversity unable to run when sequence counts are low?

fixed_filtered_table.qza (2.4 MB)

0 Likes

(Stephanie Orchanian) #4

I multiplied my OTU table by 10^6 to get my sequence counts over 1 and that worked!

1 Like

(Mehrbod Estaki) #5

Glad you got it working @Stephanieorch!
For completeness, I believe the reason why it was failing was because these were non-integer values as per the scikitbio description requirement and not because sequence counts were low per se. So multiplying these to create integers circumvented that.

2 Likes