Alpha Diversity Commands not running

Hi all -
I am having trouble running some alpha-diversity tests and I am not sure what's going on here. It seems to only allow me to run faith_pd test, none of the other options within that string (here, I am trying to run Margalef). I ran --help, and got this - image again,faith_pd is the only option. This same set of commands worked fine for some tests I ran a few days ago, but since updating to qiime2-2021.11, I have been running into this problem, so I am wondering if its a problem on my side or a potential bug. Here is what I get when running "qiime diversity alpha-phylogenetic":

Any ideas?
Thank you!

Hi @Hayley_Guay!

Yes indeed - the only phylogenetic alpha diversity measure in this plugin is faith_pd.

I suggest you double-check your commands - is it possible you ran alpha instead of alpha-phylogenetic?

The alpha command does have a margalef metric, which is a non-phylogenetic measure of alpha diversity (which is why its in alpha and not alpha-phylogenetic).

I hope that helps, and keep us posted!



This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.