Alignment and feature-table plugin errors with rep-seqs file?

Hi QIIME wizards!

I'm experiencing what's probably an easily fixable problem, but I can't figure out what could be going wrong. I'm getting errors whenever I run either of these commands using my rep-seqs file immediately after running DADA2:

qiime feature-table tabulate-seqs --i-data rep-seqs.qza --o-visualization rep-seqs.qzv

qiime alignment mafft --i-sequences rep-seqs.qza --o-alignment aligned-rep-seqs.qza

Here are the plugin errors and debug info:

These same commands have worked for me many times on very similar datasets, and they're still working on other rep-seqs files as well. I was able to make a feature table visualization, and everything looks normal to me there.

Any opinions would be really appreciated! I'd rather not have to run DADA2 again since it takes nearly two days on this dataset, but if that's necessary, it's fine.

Thanks!

Hey there @natavicula!

Can you please run the following and provide the output here?

qiime tools peek rep-seqs.qza

and

qiime tools validate rep-seqs.qza

Thanks! :t_rex: :qiime2:

Hi @thermokarst! Thanks for your help. Also, cool name-- these samples are actually from Alaskan tundra streams!

Here's the output from those commands:

1 Like

Hey there @natavicula!

Thanks for the screenshot! Looks like you might’ve transposed some filenames when you ran q2-dada2 — the type for this file is SampleData[DADA2Stats] - which is the output type for the --o-denoising-stats flag — my guess is that if you run peek on the file that you thought was your denoising stats you will find a FeatureData[Sequence] artifact!

PS -

Cool! I have spent a lot of time in that part of the world — once upon a time I used to do a bit of permafrost engineering work! :snowflake:

Ohhh, yup. I actually managed to overwrite my rep-seqs file with my denoising stats file. I have regrets. Thanks for your patience.

And that’s so awesome! Permafrost fans unite!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.