align-to-tree-mafft-fasttree output-dir not working

Hi, I’m using 2020.8 and I’ve noticed when I run align-to-tree-mafft-fasttree, the trees are generated, but the output-dir command is not working properly. The directory gets created, but the tree files end up in the current working directory. I’m not sure if this is a bug or if it’s something I’m doing, so I thought I’d ask here.

This is the code I’m running:

qiime phylogeny align-to-tree-mafft-fasttree
–i-sequences rep-seqs-filtered2_table-16S-only.qza
–o-alignment aligned-rep-seqs-filtered2_table-16S-only.qza
–o-masked-alignment masked-aligned-rep-seqs-filtered2_table-16S-only.qza
–o-tree unrooted-tree-filtered2_16S.qza
–o-rooted-tree rooted-tree-filtered2-16S.qza
–p-n-threads auto
–output-dir phylo_16S


Hey there @rhizorick, let's take a closer look at the help text for the --output-dir flag:

--output-dir PATH       Output unspecified results to a directory

So what that is saying, is any results that aren't explicitly specified should be saved into the directory specified here. You are specifying all 4 of the outputs here:

so, there are no unspecified outputs by the time we get to the --output-dir flag.

I see two potential solutions.

One, you can manually make the output dir yourself, and specify the output paths into that dir:

mkdir phylo_16S

qiime phylogeny align-to-tree-mafft-fasttree \
  --i-sequences rep-seqs-filtered2_table-16S-only.qza \
  --o-alignment phylo_16S/aligned-rep-seqs-filtered2_table-16S-only.qza \
  --o-masked-alignment phylo_16S/masked-aligned-rep-seqs-filtered2_table-16S-only.qza \
  --o-tree phylo_16S/unrooted-tree-filtered2_16S.qza \
  --o-rooted-tree phylo_16S/rooted-tree-filtered2-16S.qza \
  --p-n-threads auto

Or two, you can allow the command to automatically name the files, and use the --output-dir flag:

qiime phylogeny align-to-tree-mafft-fasttree \
  --i-sequences rep-seqs-filtered2_table-16S-only.qza \
  --p-n-threads auto \
  --output-dir phylo_16S

Hope that helps! :qiime2:

Ah, I see! I was a little confused by the terminology in the help text. What you’re saying makes perfect sense. I’ll modify my code. Thank you!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.