403 Forbidden occured when accessing localhost:8080 using galaxy/docker on MacOS

After I run the command
docker run -d -p 8080:80 -p 8021:21 -p 8022:22 -v $HOME/q2galaxy_data/:/export/ Quay
and then tried to accessing http://localhost:8080 from the broswer,
a error 403 Frobidden nginx/1.14.0 (Ubuntu) showed.
How should it be solved?

Hi @fusho96,

Welcome to the :qiime2: forum!

Would you be able to provide a screenshot of what you are seeing and the port configuration (the panel where you provide the numbers like 8080).

It seems strange because you are getting a 403 from nginx, which means some part of the container is in fact working.

Thank you! :lizard:


Hi @lizgehret ,
thank you very much for your response!
I apologize if this question seems trivial and for taking up your time.

Initially, I only checked the content on GitHub and hadn't configured ports beforehand.

Your question and the video of q2galaxy were helpful,
and I've successfully completed the port configuration and accessed the page.

Thank you for your patience and assistance.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.