When using DADA2, can I adjust the number of thread of R?

Hi, this is Yunju.

I am working with DADA2 and it takes long time as I anticipated.
However I checked the number of thread of R, it was just ‘1’.
(I thought DADA2 running is mainly composed of R.

So, I wonder can I adjust that to improve the working time of DADA2?
This is the script I used.

+) My data is composed of 491294 sequences(Miseq, Paired-end).
DADA2 is working for 72hrs till now.

(qiime2-2017.7) Yunxx-MacBook-Pro:workdir yunju.xxx$ qiime dada2 denoise-paired --i-demultiplexed-seqs menifast.qza --o-table 20170824table.qza --o-representative-sequences 20170824_repseq.qza --p-trim-left-f 0 --p-trim-left-r 0 --p-trunc-len-f 240 --p-trunc-len-r 240

Hey @Yunju,

To answer the title of your post, yes, just add this option:

 --p-n-threads 4

(Or whatever number makes sense to you. You can use 0 for all available cores.)

If you run --help on the command, you should see some documentation on this and other options as well.

Thank you so much Ebolyen! :slight_smile:
I will try again.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.