Warning Message During DADA2 Analysis

I would like to ask about the following warning message I received while running DADA2 on QIIME2.

Warning message:
package ‘optparse’ was built under R version 4.2.3
R version 4.2.2 (2022-10-31)

The QIIME2 that I am using is qiime2-amplicon-2023.9, and I have installed it naively via conda on a MacBook Pro (M1 Max).

I have seen similar topics on this forum, but I am not sure if I need to do anything about the warning message. I tried to upgrade the R version, but it was not possible because it was competing with other packages.
Is it acceptable to ignore the warning? I tried different versions of QIIME2, but I got the same warnings after version 2022.11.

Hi @microbiome_25,

You can disregard that warning message - this type of warning appears when you load a package that was built under a version of R different to the one you are running. Unless you run into any R related errors while running DADA2 (or any other package that uses R), this is typically fine to ignore.

Cheers :lizard:

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.