VirtualBox Shared Folders

Hi @thermokarst, thanks for your efforts!

I gave the new VBox image a test. The disk space problem seems to be solved. Awesome! :slight_smile:
However my problem with the Shared_Folder is still there. In QIIME 1 the Shared_Folder was located in /home/qiime/Desktop after installing the vbox guest addition. In QIIME 2 it does not appear in this or any other path. I tried several other configurations for the Shared_Folder, but could not make it work.

I’m happy to get any further support and sorry to bug you again!

Hi @Mechah - I split this off into a new topic, that way it shows up in the forum's search a bit better. Here are a few screenshots to get you set up with shared folders:

1. Install Guest Additions

After clicking on the CD icon in the lower left, click on "Run Software" in the upper right. Enter the password when prompted.

When installation is done, your screen should look like the following. Follow the prompt and press "Return"

2. Set up a shared folder

In the menubar, select 'Devices' -> 'Shared Folders' -> 'Shared Folders Settings' (note, this might be slightly different on Windows or Linux systems, please check the official VirtualBox Docs):

Click on the green plus sign/folder on the right side of the window, you should see a new screen prompting you for info:

Click on the 'Folder Path' input, and using the file browser (by selecting the option 'Other...'), select the folder you want to share with the VM. I chose my Desktop ('/Users/matthew/Desktop' on my Mac). Make sure to select 'Auto-mount' and 'Make Permanent', if you don't want to repeat these steps every time you launch the VM. Also note, the 'Folder Name' option (which VirtualBox will auto-suggest a value for) is the name of the mounted folder inside of your VM. From what I understand, VirtualBox will always prepend an sf_ to that value ("sf" for "shared folder"). So in this case, the folder name will be sf_Desktop. The full path when mounted is /media/sf_Desktop. If I chose to name the 'Folder Name' something like 'foo', then the mounted path would be /media/sf_foo.

Click 'OK' on both dialogs to save your changes.

3. Reboot

Click the gear in the upper right of the screen, then 'Shut Down...', then 'Restart'.

4. Enjoy!

Once you are rebooted and logged in, you should see your shared folder in the file browser (the icon on the left bar that looks like a file cabinet:

The files there are the files on my Mac's desktop! I can also access the mounted folder via the Terminal at /media/sf_Desktop:

Hope that helps!

@thermokarst good idea to split this topic off.

Thanks for your step by step instructions (it’s a bit embarrassing that I actually need it). So one thing I was not aware of was that the Shared_Folder gets a “sf” prefix and is located in /media. Ok, fine.
However, the shared directories in /media are empty. So unfortunately they do not show my expected files of the host system and when I create a file in ubuntu it does not pop up either…

There is a bit of discussion about this in the VirtualBox Manual, in Section 4.3.2, in case you wanted to get some more info about that.

The only thing that comes to mind at this point is the ensure that you are using an up-to-date version of VirtualBox — I am running 5.1.4 on my work computer. Also, could you show a screenshot of your “Shared Folders” settings (like this one)? If you aren’t comfortable posting it feel free to send in a direct message to me. Thanks!

I'll give it a try with a new version of the VirtualBox and on a different PC.

Here are my current settings of the Shared Folder (hope you do not mind that this is in german...).

I also have one failure during the boot process of ubuntu. Could this be another hint to my problems?

thanks again!


You were absolutely right. My errors seem to be associated with the old VirtualBox version I’m running. After some testing with my office PC I could give the following resumé:

Everything works fine with VB vers. 5.1.14
Thanks for the new vdmk image with increased disk space.

VB vers. 4.3.24
The Shared Folder can be created, but do not show expected files.

VB vers. 5.0.16
can not boot correctly: error message “error writing sector 0X14d02 to hd0” and after that you have a read-only file system.

Now, I can’t wait for the new QIIME 2 version, to process my paired-end stiched reads as well…

Thanks for your support during the last days!