Unable to run vsearch cluster-features-de-novo


I am trying to run vsearch cluster-features-de-novo using qiime2-2020.8. Here is the code I have been trying to run:

qiime vsearch cluster-features-de-novo
--i-table nc_merged_table.qza
--i-sequences nc_merged_seqs.qza
--p-perc-identity 0.97
--o-clustered-table 97_otu_table_nc.qza
--o-clustered-sequences 97_rep-seqs_nc.qza

It seems to work well until I encountered the following error:

Reading file /tmp/tmpo6cy75_r 100%
335415543 nt in 816440 seqs, min 195, max 451, avg 411
Sorting by abundance 100%
Counting k-mers 100%
Clustering 100%
Sorting clusters 100%
Writing clusters 100%
Clusters: 245334 Size min 1, max 730, avg 3.3
Singletons: 150055, 18.4% of seqs, 61.2% of clusters
File "/home/user/anaconda3/envs/qiime2-2020.8/lib/python3.6/site-packages/q2cli/commands.py", line 329, in call
results = action(**arguments)
File "", line 2, in cluster_features_de_novo
File "/home/luser/anaconda3/envs/qiime2-2020.8/lib/python3.6/site-packages/qiime2/sdk/action.py", line 245, in bound_callable
output_types, provenance)
File "/home/user/anaconda3/envs/qiime2-2020.8/lib/python3.6/site-packages/qiime2/sdk/action.py", line 418, in callable_executor
spec.qiime_type, output_view, spec.view_type, prov)
File "/home/user/anaconda3/envs/qiime2-2020.8/lib/python3.6/site-packages/qiime2/sdk/result.py", line 273, in _from_view
File "/home/user/anaconda3/envs/qiime2-2020.8/lib/python3.6/site-packages/qiime2/core/archive/archiver.py", line 316, in from_data
Format.write(rec, type, format, data_initializer, provenance_capture)
File "/home/user/anaconda3/envs/qiime2-2020.8/lib/python3.6/site-packages/qiime2/core/archive/format/v5.py", line 21, in write
File "/home/user/anaconda3/envs/qiime2-2020.8/lib/python3.6/site-packages/qiime2/core/archive/format/v1.py", line 26, in write
prov_dir, [root / cls.METADATA_FILE, archive_record.version_fp])
File "/home/user/anaconda3/envs/qiime2-2020.8/lib/python3.6/site-packages/qiime2/core/archive/provenance.py", line 318, in finalize
File "/home/user/anaconda3/envs/qiime2-2020.8/lib/python3.6/site-packages/qiime2/core/archive/provenance.py", line 309, in write_citations_bib
self.citations.save(str(self.path / self.CITATION_FILE))
File "/home/user/anaconda3/envs/qiime2-2020.8/lib/python3.6/site-packages/qiime2/core/cite.py", line 71, in save
bp.dump(db, f, writer=writer)
File "/home/user/anaconda3/envs/qiime2-2020.8/lib/python3.6/site-packages/bibtexparser/init.py", line 111, in dump
UnicodeEncodeError: 'latin-1' codec can't encode character '\u0161' in position 3969: ordinal not in range(256)

Plugin error from vsearch:

'latin-1' codec can't encode character '\u0161' in position 3969: ordinal not in range(256)

See above for debug info.

We tried to fix the error using the following method:

  1. activating qiime2
  2. typing the following in the terminal export PYTHONNOUSERSITE=True
  3. typing the following: export LC_ALL=en_US
  4. run the analysis

However it still does not work. Does anyone have any idea to fix this issue?
Thank you very much in advance

Hi @leila, I suspect you're on the right track here (looking at locale environment variables). You're probably looking for a locale that specifies .utf-8 or .UTF-8. The formatting (caps) depends on your system, and must be a perfect match.

I did a quick search for your error message, and there are a bunch of good topics troubleshooting this already. Start here, see if you can figure out what's going on, and let us know if it keeps giving you trouble!

Thank you very much for your quick reply and advice!! I therefore typed the following command : LC_ALL=en_US.UTF-8 and it worked :smile:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.