Trouble installing qiime 2 within a conda environment

Hello everyone. I am new around here, hope I use the forum right. Also I am not a native English speaker, sorry for any mistakes.

I have searched for answers on other topics and I have found similar issues, but not quite the same, so I could not solve the problem. Sorry if I am being repetitive.

I am installing qiime2 on a WSL conda environment, following these instructions:
https://docs.qiime2.org/2022.2/install/native/

The first time I ran the code, my laptop froze when I was installing qiime 2 within the conda environment, so I had to turn it off. Now I get "qiime: command not found" when trying to run "qiime --help", so I tried to install it again, but I keep getting the following error:

(base) [email protected]:~$ conda env create -n qiime2-2022.2 --file qiime2-2022.2-py38-osx-conda.yml
Collecting package metadata (repodata.json): done
Solving environment: failed

ResolvePackageNotFound:

  • appnope=0.1.2
  • libgfortran=5.0.0

I feel it is a simple matter, but I am a total newbie at this and have not been able to solve it myself. I would appreciate it if you could help me! Thanks!!

1 Like

Hello!

So do I! Forgive my errors as well.

I think it is an issue here. Your installation was interrupted. Could you try to delete failed environment (if it is already exists) with the following command:

conda env remove -n qiime2-2022.2 --all

and then clean all unused packages:

conda clean --all

After it try to install qiime2 again. Hope that it will help.

3 Likes

Thank you for your quick response and I am sorry it took me a while to answer.

I did what you suggested and it worked! Thank you very much, I appreciate it a lot!!

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.