Taxonomy assignment with classify-consensus-blast

Hi Community,

I have been running into the same wall with the following code:

$ qiime feature-classifier classify-consensus-blast
--i-query rep-seqs.qza
--i-reference-reads MetaCOXI_Seqs.qza
--i-reference-taxonomy MetaCOXI_Taxonomy.qza
--output-dir taxonomic-assignment

rep-seqs.qza (2MB) is my sequences read from water environmental sample. There are 22,104 reads and each about ~313bp.
MetaCOXI_Seqs.qza (687MB) & MetaCOXI_Taxonomy.qza (109MB) are COI sequences/taxon data of metazoan imported from a published study (MetaCOXI: an integrated collection of metazoan mitochondrial cytochrome oxidase subunit-I DNA sequences | Database | Oxford Academic).
All the above artifacts were produced under qiime2-2023.2 environment in anaconda (conda version: 23.1.0)

I have tried running the above code on a local computer, and on high-performance computing with various settings but I keep getting the same error as following:

Plugin error from feature-classifier:

Command '['blastn', '-query', '/tmp/jobtmp-myname-1219526/qiime2/myname/data/b033b950-6ff6-408f-9fd9-f1dbf760a808/data/dna-sequences.fasta', '-evalue', '0.001', '-strand', 'both', '-outfmt', '6', '-subject', '/tmp/jobtmp-myname-1219526/qiime2/myname/data/7d6802ec-790f-4be2-806a-280664950f2d/data/dna-sequences.fasta', '-perc_identity', '80.0', '-qcov_hsp_perc', '80.0', '-max_target_seqs', '10', '-out', '/tmp/jobtmp-zhongyue-1219526/q2-BLAST6Format-zai5m1v0']' died with <Signals.SIGKILL: 9>.
which is not helping me a lot.

Anybody got the same err before and got it sorted out?

with great thanks,

Welcome to the forum!
Looks like it is a memory issue (not enough of RAM on the machine).

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.