some questions about cutadapt demux-paired

Dear developers,
Recently I meet a question about cutadapt. I succeeded in getting the result of demux, but I found that some samples had no sequence and some had few, so I was wondering if there was any way to solve it. Or proceed to the next step. Here is the pic of my resut. Thanks a lot~ :grinning:

Hi @LiuZjiia ! Welcome to the forum!
There may be several reasons why some samples are failing to be demultiplexed:

  1. PCR failure. You can verify it by searching for your barcode from failed samples in multiplexed fastq files. If you can not find a lot of sequences there - sequences were not amplified. In such case, there is nothing to do here.
  2. Errors on demultiplexing step. You can try to disable or to increase allowed error rate in cutadapt to see if it will fix the issue.
  3. Error in metadata. Double check if you are providing the right barcodes for demultiplexing.
  4. Cutadapt is not handling your data well.

PS. Which sequencing platform was used to produce your fastq files?
I have a similar issue with NovaSeq data as described here. Manual search showed that I have a lot of sequences with barcodes from failed samples.
So I decided to run demultiplexing step outside of Qiime2 by Sabre and GBSX tools. I got similar results with both tools by setting allowed mismatches to 0, and this way I recovered failed with cutadapt samples. I tried it with 2 different NovaSeq runs, in both cases sabre and gbsx demultiplexed all samples, meanwhile some samples were lost with cutadapt. But it is not an official advice since I am not sure yet what went wrong with my datasets.

1 Like

Thanks for replying, the data comes from my senior, so it has been through a long time. As I know, the data was sequenced by Illumina MiSeq. Actually I tried improve error rate to 0.2, and the I get data indeed, but I'm afraid this way may influence subsequent analysis, and here is my new result.(Plus: another two pics are the result of run demux summary command after getting qza file wen set the error rate 0.1 and 0.2 respectively)

What primer set and amplicon region are you using? Also, I often recommend that users apply the following flags when using cutadapt:

  --p-match-read-wildcards \
  --p-match-adapter-wildcards \
  --p-discard-untrimmed \

For more detail see:



My primer is based on 16S rDNA(V4-V5)
forward: 515F: 5ʹ-barcode-GTGCCAGCMGCCGCGG)-3ʹ
Anyway, I don’t mind that this time, and just wait for outcome. I will check for errors in a few days, I don’t have enough time recently :sleepy:
Thank you all guys~ :muscle:

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.