SOLVED: Permdisp error message

Dear qiime2 Technical Support team,

I’m running qiime2-2019.10 both on the server and on VM. While running permdisp test with the command:

qiime diversity beta-group-significance --i-distance-matrix unweighted_unifrac_distance_matrix.qza --m-metadata-file metadata.tsv --m-metadata-column Date --p-method permdisp --o-visualization unweighted_unifrac-Date-permdisp.qzv

The following error message rased:

/opt/miniconda3/envs/qiime2-2019.10/lib/python3.6/site-packages/skbio/stats/distance/_permdisp.py", line 264, in _config_med
X = x.values[:, :-1]
IndexError: too many indices for array: array is 1-dimensional, but 2 were indexed

P.S. The test worked perfectly on qiime2-2019.4 (both qiime2 old and new requirements file attached).qiime2_2019.4_requirements.txt (2.3 KB) qiime2_2019.10_requirements.txt (2.4 KB) It looks like the error message is from the scikit-bio package.

P.P.S. SOLVED by performing the command at the latest available version of qiime2-2020.8

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.