Running Closed Reference starting from a FASTQ file

I’m trying to run closed reference using the data I’ve downloaded from Qiita but I’m unsure of what commands I should run. I currently have the GG 99% taxonomy and sequences, my metadata, and my FASTQ file. I tried importing my FASTQ file but I keep getting an error saying I’m not pointing to a directory. Which import command should I be using for my FASTQ that has already been split, demuxed, and trimmed. Also, what is the closed reference command? If the command required any additional files that I didn’t list, how can I create them? Thank you.

Hey there @Stephanieorch!

Have you taken a look at the Importing data tutorial?

Is there only one file? Or many? Either way, the importing tutorial has several options listed for you to get started.

Have you had a chance to look at the OTU Clustering tutorial?

Hope that helps - let us know if you need a hand! :qiime2: :t_rex:

I pulled out my FASTA file from Qiita at the trimming step and imported it as a FeatureData[Sequence]. It worked, but then when I run the qiime vsearch dereplicate-sequences command step to get table.qza I got an error saying that “‘sequences’ is not a subtype of SampleData[JoinedSequencesWithQuality] | SampleData[SequencesWithQuality] | SampleData[Sequences]” so I’m unable to get my table to input into the closed reference command. To fix this, I instead imported my FASTA file as SampleData[Sequences]. I was able to run the dereplicate-sequences command, but then I get an error at the qiime vsearch cluster-features-closed-reference step that says “‘sequences’ is not a subtype of FeatureData[Sequence]”.

Then I tried just pulling out my 97% closed reference table from Qiita and using that as my table but then I get the error that my seqs.qza and table.qza don’t match.

So I tried pulling sequences out of that final 97% Closed Reference biom table from Qiita so that the table and seqs will match but I get the error that the table isn’t a DNAFASTAFormat file.

:+1:

That’s the correct process for qiime1-style demux data (e.g., form QIITA). Continue following the steps in the OTU clustering tutorial that @thermokarst linked to.

You must be using the wrong file as input. Make sure you are using the sequences file output by dereplicate-sequences.

If in doubt, always run:
qiime tools peek file.qza

to inspect the type.

dereplicate-sequences will output a table for you to use.

I hope that helps!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.