.qza profile not readable

Recently, i tried to use qiime2 in the ubuntu subsystem under windows 10. It was installed successfully, but i ran into an unexpected error when trying to import qza files from the section of " Fecal microbiota transplant (FMT) study: an exercise". The files were downloaded from the website and renamed, the command was exactly the same in the tutorial.
qiime demux summarize
–i-data fmt-tutorial-demux-1.qza
–o-visualization demux-summary-1.qzv
Error: There was a problem with the command:
(1/1) Invalid value for ‘–i-data’: ‘fmt-tutorial-demux-1.qza’ is not a QIIME
2 Artifact (.qza)
then i ran the commad
qiime tools validate fmt-tutorial-demux-1.qza
Error: There was a problem with the command:
(1/1) Invalid value for ‘ARTIFACT/VISUALIZATION’: File ‘fmt-tutorial-
demux-1.qza’ is not readable.
Is this system incompetent in runing qiime2 or something wrong with my settings ?
Very grateful for your help.

Hello @Wangxp, this error is likely occurring because you do not have the necessary permissions to read the file. I’m not really sure how or why that would be the case given the environment you described, but try running the following command and see if it fixes your issue

chmod +r fmt-tutorial-demux-1.qza

Thank you for your reply. I re-installed the subsystem, now it‘s back to normal.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.