Questions about import formatting and Fastq manifest file

Hi everyone,

Sorry if this is asked a lot, but I can't seems to figure this out despite looking at many similar forum posts for this....I'm still brand new to this :sob:

I was looking to import my fastq files into Qiime2. This is the action I'm putting in the terminal:
qiime tools import \
--type 'SampleData[PairedEndSequencesWithQuality]' \
--input-path stability.files.csv \
--input-format PairedEndFastqManifestPhred33 \
--output-path paired-end-demux.qza

I chose 'SampleData[PairedEndSequencesWithQuality]' since each sample has forward and reverse reads. I put the my csv file as an input. I'm not sure if it is supposed to be PairedEndFastqManifestPhred33 format, since it's giving me this error...

The error I got was:

There was a problem importing stability.files.csv:

stability.files.csv is not a(n) PairedEndFastqManifestPhred33 file

Here's my csv file also: stability.files.csv (1.3 KB)

Any help would be appreciated! :sweat_smile:

Hey there @pzd115 --- you are missing the header for the manifest file, as well, the columns aren't quite right. Check out this section of the docs for guidance:

Keep us posted! :qiime2: :t_rex:

1 Like

I think I fixed some of the formatting, but I'm still getting the same error.

stability.files.csv (2.7 KB)

What do you see when you run this command:

ls /Documents

I ask because that is a weird directory location, and I suspect that in fact your files are somewhere like /Users/pzd115/Documents/.

I'm running it in virtual box, so the path seems different from that.

That is the pwd I'm getting, although I left out the /home/qiime2/ part

Yep, exactly — you need to reference the absolute path in your manifest. Just update to match the actual locations on disk and you should be set.

Still getting the same error message about not being a Phred33 file... Must be some silly mistake I'm doing in the csv file itself?

stability.files.csv (3.1 KB)

I got it working!! I had the same issue as someone earlier on this forum… I saved mine as CSV UTF-8 (comma delimited) not as a regular CSV (comma separated values)

Thanks again for helping!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.