Qiime2 installation through wsl- issue with wget

Hello all, I'm new to qiime2 and I'm trying to install through wsl. Using the command

 wget https://data.qiime2.org/distro/core/qiime2-2022.8-py38-linux-conda.yml

I get the following output

--2022-12-12 16:33:06--  https://data.qiime2.org/distro/core/qiime2-2022.8-py38-linux-conda.yml
Resolving data.qiime2.org (data.qiime2.org)...
Connecting to data.qiime2.org (data.qiime2.org)||:443... connected.
HTTP request sent, awaiting response... 302 FOUND
Location: https://raw.githubusercontent.com/qiime2/environment-files/master/2022.8/release/qiime2-2022.8-py38-linux-conda.yml [following]
--2022-12-12 16:33:07--  https://raw.githubusercontent.com/qiime2/environment-files/master/2022.8/release/qiime2-2022.8-py38-linux-conda.yml
Resolving raw.githubusercontent.com (raw.githubusercontent.com)..., 2405:200:1607:2820:41::36
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)||:443... failed: Connection timed out.
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|2405:200:1607:2820:41::36|:443... failed: Network is unreachable.

I have tried running it again with my firewall switched off, I get the same error. Also, I'm sure it is not a problem with wget, as I am able to successfully run

wget github.com

with no errors.
Kindly provide suggestions on how to debug this error. Thanks in advance

Hello @Heisenberg711, are you still getting the error? If I run the command exactly as you pasted it here I am able to download the file. It may have just been a temporary hiccup with the server or something.

I have been running the code for several days now, and I keep getting the same error. If you are able to download it, it probably means the server side is working correctly. But I do not know how to debug this error.
Kindly provide insights on how to solve this issue.

Are you able to access that URL from your system outside of WSL?

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.