qiime2 import error -1

Hi
I am trying to import the manifest file into QIIME2, but I get an error as “no such command import-type” and I have verified that I am using 2019 QIIME2. Can you please help with this?
the code is used: qiime tools import
–type ‘sampledata[pairedendseqienceswithquality]’
–input path /home/qiime2/desktop/manifest.xlsv
–output-path pairend-demux.qza
–source format pairedendfastqmanifestphred64

Hi @Vishnu_Vijai_Vijayak,

It looks like you may be missing a couple of small but very important details. If you want to type your command on multiple lines, you need to use the \ character to indicate a line break. Otherwise, the command will be combined together without line breaks. So in your case, your terminal actually interprets your command as qiime tools import–type ‘sampledata[pairedendseqienceswithquality]’–input path /home/qiime2/desktop/manifest.xlsv–output-path pairend-demux.qza–source format pairedendfastqmanifestphred64

The tools plugin does not have an action called import-type, hence the error No such command 'import-type'.

For example, notice the difference in behavior between the following two snippets. Copy/paste these into a terminal and observe what happens.

echo "a"
"b"

Notice how the behavior differs from this one:

echo "a" \
"b"

Also note that options need to be specified with two dashes, --, not a single dash, -, as is the case in the example you shared. If you type in qiime tools import --help you will see the following:

➜ qiime tools import --help
Usage: qiime tools import [OPTIONS]

  Import data to create a new QIIME 2 Artifact. See https://docs.qiime2.org/
  for usage examples and details on the file types and associated semantic
  types that can be imported.

Options:
  --type TEXT             The semantic type of the artifact that will be
                          created upon importing. Use --show-importable-types
                          to see what importable semantic types are available
                          in the current deployment.                [required]

There you can see exactly what options there are and that they are prepended with --.

I hope that helps!

Hey! thanks for that, but still i am not able to import, i am using qiime2 in mac. Can you please tell me how to do find the absolute file path? I right clicked the folder in the desktop and in properties i found the path. for instance,
AS1 /home/qiime2/16se1/AS1_combined_R1.fastq.gz forward. This is is format i am using in excel and I import using the command: qiime tools import\
–type ‘SampleData[PairedEndSequencesWithQuality]’
–input-path codesmanifest
–output-path paired-end-demux.qza
–source-format PairedEndFastqManifestPhred64. I named the excel file as codesmanifest. It gives an error saying the file is not found and my sequences are demultiplexed.

On Mac OS, dragging a file or directory into your terminal will result in pasting the absolute path.