Qiime2 error while executing the import command

Hi,
I am new to qiime2 and command lines. I am trying to execute this command
qiime tools import --type EMPPairedEndSequences/ --input-path EMPPairedEndSequences/forward.fastq EMPPairedEndSequences/reverse.fastq --output-path EMPPairedEndSequences/emp-paired-end-sequences.qza
but qiime complains Error: Got unexpected extra argument (EMPPairedEndSequences/reverse.fastq)
How will it take the forward and reverse fastq together in one command?
Can someone help me and kindly tell what I am doing wrong.

Hi,
I installed qiime2 using miniconda.
Now I am trying to run the command :

qiime tools import --type /home/moloy/EMPPairedEndSequences/ --input-path /home/moloy/EMPPairedEndSequences/forward.fastq --output-path /home/moloy/EMPPairedEndSequences/emp-paired-end-sequences.qza
Traceback (most recent call last):
File “/home/moloy/miniconda3/envs/qiime2-2018.8/lib/python3.5/site-packages/q2cli/tools.py”, line 140, in import_data
view_type=input_format)
File “/home/moloy/miniconda3/envs/qiime2-2018.8/lib/python3.5/site-packages/qiime2/sdk/result.py”, line 182, in import_data
type_ = qiime2.sdk.parse_type(type_)
File “/home/moloy/miniconda3/envs/qiime2-2018.8/lib/python3.5/site-packages/qiime2/sdk/util.py”, line 62, in parse_type
type_expr = eval(string, {‘builtins’: {}}, locals_)
File “”, line 1
/home/moloy/EMPPairedEndSequences/
^
SyntaxError: invalid syntax

An unexpected error has occurred:

invalid syntax (, line 1)

See above for debug info.
Can someone kindly tell me what is the problem ? Is qiime2 not installed properly.

Your command contains an extra argument, see the example here.

There are actually multiple issues with your command but I have fixed it here. This will work assuming you have a directory called “EMPPairedEndSequences” in your current working directory that contains only a forward.fastq.gz, reverse.fastq.gz, and barcodes.fastq.gz files, so first you need to gzip those files!:

cd EMPPairedEndSequences
gzip forward.fastq
gzip reverse.fastq
gzip barcodes.fastq
cd ..
qiime tools import \
    --type EMPPairedEndSequences \
    --input-path EMPPairedEndSequences \
    --output-path emp-paired-end-sequences.qza

Good luck!

1 Like

Hey @Nicholas…thanks…it worked! I am new to command line and doing things all on my own…my lab does not have any informatics support staff to guide me. Thanks a lot for your help. I will write more on the forum because people here help a lot. So kindly don’t mind.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.