QIIME2 activation appears to work, but installation test doesn't work (Windows 10)

Hello!

I am new to Qiime2 and I installed anaconda3 using Ubuntu and I created my environment, etc.

Then using the command lines on the QIIME2 docs for version qiime2-2021.4 (WSL => native conda installation => Windows Subsystem for Linux (64bit)) I created the QIIME2 environment, activated the QIIME2 environment, but when I go to confirm installation with either the “qiime info” or “qiime --help” script, it just says “qiime: command not found.” Everything seemed to work up until this point with no errors, so I am not sure why the installation didn’t work.

Thanks for any assistance!
Alicia

Hi @aliciarlamb!

Are you running the qiime info command inside a WSL shell, with your QIIME 2 conda env activated? That error you shared above implies that the answer might be “no” - please try again and let us know! If you’re still stuck, maybe you can send some screenshots, or maybe more detailed description of the steps you took, including the commands you ran leading up to running qiime info.

:qiime2:

Hi @thermokarst,

Thanks for responding - to backtrack on my steps, I used Ubuntu 20.04 and after setting my username and password, updating ("sudo apt-get update”) and upgrading (“sudo apt-get upgrade”), I downloaded the anaconda software package using the command, “curl -O https://repo.anaconda.com/archive/Anaconda3-2020.11-Linux-x86_64.sh” and installed using “bash Anaconda3-2020.11-Linux-x86_64.sh”. Following that, I ran “source ~/.bashrc” and then “conda list” to make sure everything was installed correctly thus far.
I created my new conda environment using “conda create – name my_env python=3”
I activated the conda environment using “conda activate my_env”
To install QIIME2, I used “wget https://data.qiime2.org/distro/core/qiime2-2021.4-py38-linux-conda.yml” to fetch the package from the server.
I used “conda env create -n qiime2-2021.4 --file qiime2-2021.4-py38-linux-conda.yml” to install the QIIME 2 package and create a new Qiime environment.
I activated using “conda activate qiime2-2021.4”
But yeah… I just get the “qiime: command not found” error for the “qiime info” command.

Thanks again!
Alicia

Hi @aliciarlamb, I noticed that you have:

Why anaconda and not miniconda as outlined here? Anaconda should work too, but I am just curious.

Is there a reason why you made the environment my_env? It appears that you were inside my_env when running the conda command to install :qiime2: ? This could explain the qiime: command not found issue. :man_shrugging:

There is no need to set up an environment prior to running the command to install :qiime2: Just make sure you are in your base environment when running this command as outlined in the instructions. A new environment will be made for you (note the conda env create -n qiime2-2021.4 ... portion of that command). :slight_smile:

2 Likes

Thank you - it worked once I didn’t use “conda activate my_env”

Honestly, I was mostly following the instructions in the following video… How to Install Qiime2 in Windows 10 ?? - YouTube

Thanks again!
Alicia

1 Like

Thanks @aliciarlamb! That video is made by a community member, and isn’t an official installation guide. The “conda activate my_env” step in that video is unnecessary, and in some versions of conda, will most likely produce an error (like you saw above). Sounds like got everything sorted out - keep us posted!

:qiime2:

1 Like