Qiime2 2023.5 M1 Mac conda conflicts

Hi everyone,

I recently switched to an M1 Mac... which has been an adventure to say the least. Anyway I am trying to install the latest qiime2 version (2023.5) using Conda within a Roesstta terminal.

I keep running into conflict issues despite not have any prior conda env active.

2023-06-23 13:48:56 (16.9 MB/s) - ‘qiime2-2023.5-py38-osx-conda.yml.3’ saved [14006/14006]

Collecting package metadata (repodata.json): done
Solving environment: / 
Found conflicts! Looking for incompatible packages.
This can take several minutes.  Press CTRL-C to abort.

I'm using miniconda3 with:

conda 23.5.0

Cheers,
Jacob Nearing

Hello @nearinj,

Did you follow the installation instructions on the qiime website to a tee? Why the .3 at the end of the file?

What does the command conda config --show channel_priority return?

Hi @colinvwood

I did the .3 is just because I tried it three different times... (wget auto adds number to the end of file if its already there).

I tried both the installation of x86/intel in my Rosetta terminal and the M1 silicone install instructions in a non-rosetta terminal.

Both arrived at similar issues with conflicts...

The return of the command: conda config --show channel_priority is:

channel_priority: strict

Perhaps making this less strict may solve the issue?

Cheers,
Jacob Nearing

Hello @nearinj,

Yep, try conda config --set channel_priority flexible and then creating the env again.

2 Likes

hi @colinvwood ,

Thanks for helping me with my issue! it seems to all be solved now :slight_smile:

Cheers,
Jacob Nearing

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.