Qiime2-2022.8 not running in Ubuntu 2022.04.1 virtual box install on Window 10 pro (Conda version : 4.14.0 conda-build version : 3.21.8 python version : 3.9.12.final.0)

(base) [email protected]:~/anaconda3$ ls
bin include phrasebooks share
compiler_compat lib pkgs shell
condabin libexec plugins ssl
conda-meta LICENSE.txt pyodbc.pyi translations
doc licensing qml var
envs man resources x86_64-conda_cos6-linux-gnu
etc mkspecs sbin x86_64-conda-linux-gnu
(base) [email protected]:~/anaconda3$ cd envs
(base) [email protected]:~/anaconda3/envs$ ls
(base) [email protected]:~/anaconda3/envs$ ls qiime2-2022.8/
bin etc include mkspecs share
compiler_compat example.cf jmods models.nex ssl
conda-meta example.nex legal phrasebooks translations
conf example.phy lib plugins var
doc fonts libexec qml x86_64-conda_cos6-linux-gnu
docs home.path man sbin x86_64-conda-linux-gnu
(base) [email protected]:~/anaconda3/envs$ conda activate qiime2-2022.8/
QIIME is caching your current deployment for improved performance. This may take a few moments and should only happen once per deployment.
Illegal instruction (core dumped)
(qiime2-2022.8) [email protected]:~/anaconda3/envs$

Hi @Karuppan,

Welcome to the :qiime2: forum!

We are no longer creating new virtual box or aws images as part of our virtual machine support. We do have a docker image available for the latest QIIME 2 release, which you can install by following these instructions.

Hope this helps!
Cheers :lizard:

C:\Users\AKK>docker run -t -i -v (pwd):/data quay.io/qiime2/core:2022.8 qiime docker: Error response from daemon: create (pwd): "$(pwd)" includes invalid characters for a local volume name, only "[a-zA-Z0-9][a-zA-Z0-9_.-]" are allowed. If you intended to pass a host directory, use absolute path.
See 'docker run --help'.

From an Academic service/training department (q2studio installation issue)

A new issue and bug report:

  1. Installation of qiime2-2022.8 was successful. qiime --help fetched the installed packages (on Ubuntu 22.04 Machine (Workstation - Intel® Xeon(R) E-2224G CPU @ 3.50GHz × 4 - 32 GB RAM - NVIDIA Corporation GP107GL [Quadro P620] GPU)
  2. Attempted to install 'q2studio-2022.8.0'
    After downloading and unzipping q2studio I tried installing it as a Python and Node.js package. Things went fine until "gevent" was downloaded.
    Then the following error messages were generated
    Downloading gevent-21.12.0-cp39-cp39-manylinux_2_12_x86_64.manylinux2010_x86_64.whl (6.2 MB)
    |████████████████████████████████| 6.2 MB 8.2 MB/s
    ERROR: Could not find a version that satisfies the requirement qiime2==2022.8.* (from q2studio) (from versions: none)
    ERROR: No matching distribution found for qiime2==2022.8.*
    npm WARN Invalid version: "2022.8"
    npm WARN q2studio-2022.8.0 No description
    npm WARN q2studio-2022.8.0 No repository field.
    npm WARN q2studio-2022.8.0 No README data
    npm WARN q2studio-2022.8.0 No license field.
    npm ERR! Linux 5.15.0-48-generic
    npm ERR! argv "/home/btis/anaconda3/envs/qiime2-2022.8/bin/node" "/home/btis/anaconda3/envs/qiime2-2022.8/bin/npm" "run" "build"
    npm ERR! node v6.11.2
    npm ERR! npm v3.10.10

npm ERR! Invalid version: "2022.8"
npm ERR!
npm ERR! If you need help, you may report this error at:
npm ERR! https://github.com/npm/npm/issues

npm ERR! Please include the following file with any support request:
npm ERR! /home/btis/q2studio-2022.8.0/npm-debug.log

I am attaching the npm-debug.log

0 info it worked if it ends with ok
1 verbose cli [ '/home/btis/anaconda3/envs/qiime2-2022.8/bin/node',
1 verbose cli '/home/btis/anaconda3/envs/qiime2-2022.8/bin/npm',
1 verbose cli 'start' ]
2 info using [email protected]
3 info using [email protected]
4 verbose stack Error: Invalid version: "2022.8"
4 verbose stack at Object.fixVersionField (/home/btis/anaconda3/envs/qiime2-2022.8/lib/node_modules/npm/node_modules/normalize-package-data/lib/fixer.js:191:13)
4 verbose stack at /home/btis/anaconda3/envs/qiime2-2022.8/lib/node_modules/npm/node_modules/normalize-package-data/lib/normalize.js:32:38
4 verbose stack at Array.forEach (native)
4 verbose stack at normalize (/home/btis/anaconda3/envs/qiime2-2022.8/lib/node_modules/npm/node_modules/normalize-package-data/lib/normalize.js:31:15)
4 verbose stack at final (/home/btis/anaconda3/envs/qiime2-2022.8/lib/node_modules/npm/node_modules/read-package-json/read-json.js:349:5)
4 verbose stack at then (/home/btis/anaconda3/envs/qiime2-2022.8/lib/node_modules/npm/node_modules/read-package-json/read-json.js:124:5)
4 verbose stack at /home/btis/anaconda3/envs/qiime2-2022.8/lib/node_modules/npm/node_modules/read-package-json/read-json.js:243:12
4 verbose stack at /home/btis/anaconda3/envs/qiime2-2022.8/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:78:16
4 verbose stack at tryToString (fs.js:456:3)
4 verbose stack at FSReqWrap.readFileAfterClose [as oncomplete] (fs.js:443:12)
5 verbose cwd /home/btis/q2studio-2022.8.0
6 error Linux 5.15.0-48-generic
7 error argv "/home/btis/anaconda3/envs/qiime2-2022.8/bin/node" "/home/btis/anaconda3/envs/qiime2-2022.8/bin/npm" "start"
8 error node v6.11.2
9 error npm v3.10.10
10 error Invalid version: "2022.8"
11 error If you need help, you may report this error at:
11 error https://github.com/npm/npm/issues
12 verbose exit [ 1, true ]

Hi @Karuppan,

Apologies for the delayed response - thanks for following up and providing all of those details!

I'm glad you were able to get QIIME 2 2022.8 up and running! q2studio is not currently maintained by the QIIME 2 core development team at this time, and we will actually be depreciating it in our November software update.

I'd recommend using q2cli (which already comes with any QIIME 2 installation) as your UI of choice, as opposed to q2studio. If you are looking for a GUI for running QIIME 2 commands, you can now use QIIME 2 within the Galaxy Toolshed!

Cheers :lizard:

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.