Qiime2-2019.1 -bash: qiime: command not found

hello! I just installed 2019.1 and every command I run gives me this… -bash: qiime: command not found

even when I try qiime --help , Im not sure what I did wrong, or even how to trouble shoot this.

Thank so much for the help! Appreciated!!!


Hey there @swillyb! We see this error when you forget to activate your conda environment!


hello! thank you for the reply!

the conda environment is activated, nothing seems to work

heres an example:

D25QV01EGQ17:~ Echo_Base$ source activate qiime2-2019.1

(qiime2-2019.1) D25QV01EGQ17:~ Echo_Base$ qiime --help

-bash: qiime: command not found

sorry Im not sure what I did wrong

I wonder if something went wrong with the install… What do you see when you run conda list after activating your environment?

I thought maybe that was the case, so I followed the instructions to uninstall

conda envremove -n qiime2-2019.1 conda clean -y --all

and I still have the same problem. When I run conda list it says:
EnvironmentLocationNotFound: Not a conda environment: /Users/Echo_Base/miniconda3/envs/qiime2-2019.1

clearly something has gone wrong …


…I reinstalled after removing of course

after removing and installing again, I have checked the envs folder for the qiim2-2019.1 folder, and its there but in it is only a conda-meta folder with nothing in it … I removed this folder and tried the install again, same result with the same folders

Hello, this seems to be an issue with my computer, as I installed on another and it is ok! so thats good news,

I am however having a problem with taxa collapse, when I run this:

qiime taxa collapse
–i-table table.qza \
–i-taxonomy taxonomysilva_new2.qza
–p-level 7
–o-collapsed-table table-collapse-level-7-silva.qza

I keep getting this Error: Got unexpected extra argument ( ), right after the table line … I have no idea what this means, I can execute other commands using the table no problem.

Thanks for the help!!


Did you forget to include \ characters at the end of the lines? It is a little hard for me to debug since it looks like maybe you didn’t copy and paste the entire error… (?)

Thanks for the reply! sorry it took me bit to get back, I was out of the lab.
this is the full error, that I got again today:

(qiime2-2019.1) Behie_Comm_Prof_121318 scottbehie$ qiime taxa collapse \

> --i-table table.qza \

Usage: qiime taxa collapse [OPTIONS]

Try “qiime taxa collapse --help” for help.

Error: Got unexpected extra argument ( )

(qiime2-2019.1) airbears2-10-142-139-90:Behie_Comm_Prof_121318 scottbehie$ --i-taxonomy taxonomysilva_new2.qza \

> --p-level 7

-bash: --i-taxonomy: command not found

(qiime2-2019.1) airbears2-10-142-139-90:Behie_Comm_Prof_121318 scottbehie$ --o-collapsed-table table-silva-7.qza

-bash: --o-collapsed-table: command not found

(qiime2-2019.1) Behie_Comm_Prof_121318 scottbehie$

thanks for the help here, I really appreciate it!!!


Perfect, thanks @swillyb!

These are both indicators that you might not have included the \ character at the end of your lines to signify a line break (see my question/comment above). Please see this post for a summary of this topic: Qiime deblur denoise-16S

I made sure to have the backslashes in, this is exactly what Ive been entering. No doubt Im doing something wring, I just don’t know what it is.

qiime taxa collapse
–i-table table.qza \
–i-taxonomy taxonomysilva_new2.qza
–p-level 7
–o-collapsed-table table-silva-7.qza

thanks for the help!


I still only see one backslash in your command. You either need to escape each line break (opt 1) or put all of the command on the same line (opt 2):

# option 1
qiime taxa collapse \
  --i-table table.qza \
  --i-taxonomy taxonomysilva_new2.qza \
  --p-level 7 \
  --o-collapsed-table table-silva-7.qza
# option 2
qiime taxa collapse --i-table table.qza --i-taxonomy taxonomysilva_new2.qza --p-level 7 --o-collapsed-table table-silva-7.qza

ok great! I promise they have the slashes, something went weird with the copy paste, however option 2 works! … i do copy paste commands so something must be odd with that… I don’t know! thank you so much!!!


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.