Qiime2 2018 error Mac OS

Hello,

I just started using qiime2 for the first time. I have a pair-end files to analyse.
I recently installed qiime2 and went through “Moving Pictures” and “Atacama soil microbiome” tutorials.
My data/samples are distributed over two files (approx half half), I started analysing the first one and got some results. Then I wanted to repeat exactly the same analysis on the second half and I got error messages from qiime2 (just by trying to import fastq.gz to qza):

(qiime2-2018.4) MacBook-Pro:qiime2-GDM-tutorial2 TB$ qiime tools import \

–type EMPPairedEndSequences
–input-path emp-paired-end-sequences
–output-path emp-paired-end-sequences.qza

Traceback (most recent call last):
File “/Users/TB/miniconda3/envs/qiime2-2018.4/bin/qiime”, line 11, in
sys.exit(qiime())
File “/Users/TB/miniconda3/envs/qiime2-2018.4/lib/python3.5/site-packages/click/core.py”, line 722, in call
return self.main(*args, **kwargs)
File “/Users/TB/miniconda3/envs/qiime2-2018.4/lib/python3.5/site-packages/click/core.py”, line 697, in main
rv = self.invoke(ctx)
File “/Users/TB/miniconda3/envs/qiime2-2018.4/lib/python3.5/site-packages/click/core.py”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/Users/TB/miniconda3/envs/qiime2-2018.4/lib/python3.5/site-packages/click/core.py”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/Users/TB/miniconda3/envs/qiime2-2018.4/lib/python3.5/site-packages/click/core.py”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/Users/TB/miniconda3/envs/qiime2-2018.4/lib/python3.5/site-packages/click/core.py”, line 535, in invoke
return callback(*args, **kwargs)
File “/Users/TB/miniconda3/envs/qiime2-2018.4/lib/python3.5/site-packages/q2cli/tools.py”, line 112, in import_data
import qiime2.sdk
File “/Users/TB/miniconda3/envs/qiime2-2018.4/lib/python3.5/site-packages/qiime2/init.py”, line 9, in
from qiime2.sdk import Artifact, Visualization
File “/Users/TB/miniconda3/envs/qiime2-2018.4/lib/python3.5/site-packages/qiime2/sdk/init.py”, line 10, in
from .action import Action, Method, Visualizer, Pipeline
File “/Users/TB/miniconda3/envs/qiime2-2018.4/lib/python3.5/site-packages/qiime2/sdk/action.py”, line 20, in
import qiime2.core.type as qtype
File “/Users/TB/miniconda3/envs/qiime2-2018.4/lib/python3.5/site-packages/qiime2/core/type/init.py”, line 9, in
from .collection import List, Set, is_collection_type
File “/Users/TB/miniconda3/envs/qiime2-2018.4/lib/python3.5/site-packages/qiime2/core/type/collection.py”, line 12, in
from .primitive import _PrimitiveBase, is_primitive_type, Metadata
File “/Users/TB/miniconda3/envs/qiime2-2018.4/lib/python3.5/site-packages/qiime2/core/type/primitive.py”, line 14, in
import qiime2.metadata as metadata
File “/Users/TB/miniconda3/envs/qiime2-2018.4/lib/python3.5/site-packages/qiime2/metadata/init.py”, line 9, in
from .metadata import (Metadata, MetadataColumn, NumericMetadataColumn,
File “/Users/TB/miniconda3/envs/qiime2-2018.4/lib/python3.5/site-packages/qiime2/metadata/metadata.py”, line 16, in
import pandas as pd
File “/Users/TB/miniconda3/envs/qiime2-2018.4/lib/python3.5/site-packages/pandas/init.py”, line 19, in
“Missing required dependencies {0}”.format(missing_dependencies))
ImportError: Missing required dependencies [‘numpy’]

At the moment I receive these error messages no matter which tutorial I am trying to run.

Hi there @Thomas_Beck!

Looks like you somehow wound up with an incomplete installation (these things happen sometimes - networks can be spotty, etc.). I would recommend removing the env and starting over:

source deactivate
conda env remove -n qiime2-2018.4

Once that is done, follow the install instructions again. Hope that helps, and keep us posted! :qiime2: :t_rex:

Thanks a lot! I will do that!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.