Qiime tools import

I am very happy to start using the new qiime 2 !!, I understand that is still in process, but try as user to get familiar with this new version !!
I try to import my file (output file generated by qiime 1 with the multiple_join_paired_ends.py command) and I used the line following command:

qiime tools import --input-path MiSeq_1/ --output-path MiSeq_2 --type “FeatureData[PairedEndSequence]” --source-format dna-sequences.fasta

and this did not work,

qiime tools import --input-path folder_join_2016_a --output-path join_2016a --type “FeatureData[PairedEndSequence]”

ValueError: Missing one or more files for PairedDNASequencesDirectoryFormat: ‘right-dna-sequences.fasta’

what would be the semantic --type for this case? thanks

Hi @cedron,

We don’t have paired-end read support in QIIME 2 yet (the next release will likely include this functionality). We don’t recommend joining your data and importing the joined reads because dada2 expects unjoined forward and reverse reads as input (this functionality isn’t available yet though).

Here’s a few options:

  • Continue analysis in QIIME 1 until you have a .biom file (i.e. perform OTU picking in QIIME 1), then import the .biom file into a QIIME 2 FeatureTable[Frequency] artifact. There are instructions here to do that.

  • Import just the forward reads into a QIIME 2 artifact and perform analyses with single-end data.

  • Wait for paired-end support in QIIME 2.

Thanks for trying out QIIME 2!