Qiime taxa collapse problem

Hi all!

I have a problem with qiime taxa collapse script.
I honestly cannot find the reason why.

I am running this on Mac Qiime 2 ( 2020. 6),

Here is the script that I am running:

qiime taxa collapse
–i-table dada2_trial/table.qza
–i-taxonomy 99_otu_classifier_trial.qza
–p-level 7
–-o-collapsed-table table_trial.qza

I made sure my taxonomy file is the one from the Greengene Database classifier
and the Error Msg seems to be related to –-o-collapsed-table ???

Here is the error msg:

(1/2) Missing option ‘–o-collapsed-table’. ("–output-dir" may also be
used)
(2/2) Got unexpected extra argument ( )
/var/lib/slurmd/job2224692/slurm_script: line 22: –-o-collapsed-table: command not found

My script includes the Missing option…so I don’t understand why it doesn’t recognize it???
Can anyone tell??? what’s wrong??

I am using this script to create an OTU table…which we need for running analysis on Galaxy/Metagenassist…on different platforms.

Hey @Sammi,

Could it be that you have one dash/minus too many before the “–o-collapsed-table” switch? (i.e., –-o-collapsed-table instead of –o-collapsed-table)

2 Likes

I tried --o-collapsed-table and -o-collapsed-table… either of them worked…with same error msg…

Hi! Could you provide a screenshot of your command with error message in the terminal?

I actually found what was wrong… there was a hidden space in between the line…

Thank you!!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.