Qiime taxa barplot only shows level 1


(Ele) #1

Good afternoon,

Trying to do my 16S taxonomic analysis after running my command:

qiime taxa barplot
–i-table table.qza
–i-taxonomy taxonomy.qza
–m-metadata-file sample-metadata.tsv
–o-visualization taxa-bar-plots.qzv

I can only see the level 1 on the visualisation for the taxonomic level. Could anyone help me find why is this? I would like to go down to at least genus level. I have used the classifier gg_13_8 from Greengages.


(Matthew Ryan Dillon) #2

Hey there @ecg!

Do you not see additional levels in the dropdown?

If not, can you please attach your QZV? Thanks! :t_rex: :qiime2:


(Ele) #3

Only this, at kingdom level.
I have checked on the forum that this can be due to taxonomy.qzv being made by different rep-seq as the table?
I am checking this now, but any other ideas are also welcomed.

Cheers @thermokarst


(Ele) #5

taxa-bar-plots.qzv (299.8 KB)


(Ele) #8

Hi,

This issue has been successfully resolved.
Thanks


(Matthew Ryan Dillon) #9

Hi @ecg, can you please share how you resolved the issue, for the sake of future users finding this thread? Also, when you withdraw most of your posts it makes it very difficult for us to follow what happened here. Just an FYI. Thanks!


(Ele) #10

I have re-runned everything from scratch and changed few things.

  • As I am working with a specific set of primers, I dowloaded the .fasta and taxonomy.tsv files from the authors of a paper online, so I could import them with qiime tools import to generate a more specific classifier - I had a lot of errors from the Greengages otus_13_8 and never knew why

  • When running qiime feature-classifier extract-reads cheked the primers as I was using the wrong ones s . Also --p-trunc-len option is not required as default is zero, and I was using a number (240) that was getting rid of most of my sample reads.

Thanks, just thought I was posting too many files.
Will do next time.

E


(system) #11

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.