Qiime feature-table merge not working

Hello,

I am having trouble with the qiime feature-table merge command, and I can’t figure out what the problem is. Terminal keeps giving me the output “-bash: qiime feature-table: command not found”, even though clearly the command is there (see the --help output below). Other qiime2 commands (like qiime diversity core-metrics-phylogenetic) are currently working. Any help would be much appreciated… thanks!

$ qiime feature-table merge
–i-tables Nereo_Temporal-filtered-table.qza
–i-tables Temporal-Nereo-base-200-seqs.qza
–o-merged-table Temporal_blade_tip_seawater_table.qza

-bash: qiime feature-table: command not found

However, when I type: (qiime2) $ qiime feature-table merge --help

I get the following output, indicating that the function is there…

Usage: qiime feature-table merge [OPTIONS]

Combines feature tables using the overlap_method provided.

Options:
–i-tables MULTIPLE ARTIFACT PATH List[FeatureTable[Frequency]]
The collection of feature tables to be
merged. [required]
–p-overlap-method [sum|error_on_overlapping_sample|error_on_overlapping_feature]
Method for handling overlapping ids.
[default: error_on_overlapping_sample]
–o-merged-table ARTIFACT PATH FeatureTable[Frequency]
The resulting merged feature table.
[required if not passing --output-dir]
–output-dir DIRECTORY Output unspecified results to a directory
–cmd-config PATH Use config file for command options
–verbose Display verbose output to stdout and/or
stderr during execution of this action.
[default: False]
–quiet Silence output if execution is successful
(silence is golden). [default: False]
–help Show this message and exit.

Hi @Brooke,

This looks a bit odd, but we’ll figure it out!
You mentioned that QIIME2 produces an output when you type qiime feature-table merge --help. Does it also work when you type qiime feature-table --help?

Also, could you paste the code you’re trying to run verbatim in a code field provided by the editor, so that I can test it out?

thanks!

Hi Tomasz,

I figured it out eventually… for some reason, the code that I was copy-pasting into the terminal from text edit had some strange formatting. When I started using text wrangler and copy-pasting QIIME commands from there, everything worked! I am still not sure exactly what was wrong, but it is recognizing the commands now. You can close this topic.

Thanks!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.