Qiime deblur denoise-16S fail-Cannot index database file

Hi,

I am trying to run qiime deblur denoise-16S but I am getting an error. This is what I am running:

qiime deblur denoise-16S --i-demultiplexed-seqs demux-filtered.qza --p-trim-length 220 --o-representative-sequences rep-seqs-deblur.qza --o-table table-deblur.qza --o-stats deblur-stats.qza --verbose

Here is my traceback:

Traceback (most recent call last):
File "/home3/torres/miniconda2/envs/qiime2-2017.4/bin/deblur", line 4, in <module>
__import__('pkg_resources').run_script('deblur==1.0.2', 'deblur')
File "/home3/torres/miniconda2/envs/qiime2-2017.4/lib/python3.5/site-packages/setuptools-27.2.0-py3.5.egg/pkg_resources/__init__.py", line 744, in run_script
File "/home3/torres/miniconda2/envs/qiime2-2017.4/lib/python3.5/site-packages/setuptools-27.2.0-py3.5.egg/pkg_resources/__init__.py", line 1499, in run_script
File "/raid60/homes/home3/torres/miniconda2/envs/qiime2-2017.4/lib/python3.5/site-packages/deblur-1.0.2-py3.5.egg-info/scripts/deblur", line 678, in <module>
deblur_cmds()
File "/home3/torres/miniconda2/envs/qiime2-2017.4/lib/python3.5/site-packages/click/core.py", line 722, in __call__
return self.main(*args, **kwargs)
File "/home3/torres/miniconda2/envs/qiime2-2017.4/lib/python3.5/site-packages/click/core.py", line 697, in main
rv = self.invoke(ctx)
File "/home3/torres/miniconda2/envs/qiime2-2017.4/lib/python3.5/site-packages/click/core.py", line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File "/home3/torres/miniconda2/envs/qiime2-2017.4/lib/python3.5/site-packages/click/core.py", line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File "/home3/torres/miniconda2/envs/qiime2-2017.4/lib/python3.5/site-packages/click/core.py", line 535, in invoke
return callback(*args, **kwargs)
File "/raid60/homes/home3/torres/miniconda2/envs/qiime2-2017.4/lib/python3.5/site-packages/deblur-1.0.2-py3.5.egg-info/scripts/deblur", line 606, in workflow
working_dir=working_dir)
File "/home3/torres/miniconda2/envs/qiime2-2017.4/lib/python3.5/site-packages/deblur/workflow.py", line 226, in build_index_sortmerna
raise RuntimeError('Cannot index database file %s' % db)
RuntimeError: Cannot index database file /home3/torres/miniconda2/envs/qiime2-2017.4/lib/python3.5/site-packages/deblur/support_files/artifacts.fa

The artifact.fna file is present in my deblur folder:

ls -lha /home3/torres/miniconda2/envs/qiime2-2017.4/lib/python3.5/site-packages/deblur/support_files drwxrwxr-x 3 torres torres 81 May 2 14:08 . drwxrwxr-x 5 torres torres 154 May 2 14:08 .. -rw-rw-r-- 4 torres torres 15M Mar 18 11:01 88_otus.fasta -rw-rw-r-- 4 torres torres 17K Mar 18 11:01 artifacts.fa -rw-rw-r-- 4 torres torres 624 Mar 18 11:01 __init__.py drwxrwxr-x 2 torres torres 36 May 2 14:08 __pycache__

I appreciate the help!

It smells like something is up with SortMeRNA. Can you please send the output from the following commands?

$ conda list | grep -i sortmerna
$ which sortmerna
$ which indexdb_rna
$ indexdb_rna --help

Best,
Daniel

Ah, one more question @pjtorres, do you know what OS and version you’re using?

Best,
Daniel

Thanks for the prompt response @wasade.

I am actually using a Centos cluster: CentOS release 6.9 (Final)

$conda list | grep -i sortmerna
sortmerna                 2.0                           0    biocore
$which sortmerna
~/miniconda2/envs/qiime2-2017.4/bin/sortmerna
$ which indexdb_rna
~/miniconda2/envs/qiime2-2017.4/bin/indexdb_rna
$ indexdb_rna -h
indexdb_rna: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by indexdb_rna)

Ahh, I see I do not have the correct indexdb_rna: /lib64/libc.so.6: version. Is there an easy way to update this with out a sudo command?

The good news is that I went ahead and tried it on my MacBook laptop OS X El Capitan (v. 10.11.6) it worked!

2 Likes

Thanks, @pjtorres. I am able to confirm this as well on one of our CentOS 6 boxes as well. The build of SortMeRNA in the biocore channel appears to have been done on a newer OS. I’m looking into whether we can just replace that build with a more general one. In the mean time, the following seemed to work for me:

$ conda uninstall sortmerna --force
$ conda install -c bioconda sortmerna==2.0

What the commands do is first remove SortMeRNA, and only that package (i.e., do not remove packages which depend on it). Then, we reinstall the package from the bioconda channel as apparently that build is more permissive. This is not an ideal solution of course, but hopefully allows you to proceed near term.

Best,
Daniel

3 Likes

Thanks @wasade. It is working on the cluster now :slight_smile:

3 Likes

Fantastic!

The binaries in the biocore channel for SortMeRNA==2.0 have been replaced, and I’m told they now work on CentOS 6, but I haven’t had an opportunity to independently verify yet. (cc @ebolyen regarding the glibc discussion on this package we were having)

Best,
Daniel

This is something we're trying to fix, it probably just involves dropping biocore from our conda-channel order (unless someone over there feels like recompiling everything with an older glibc).

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.