q2studio not working with new qiime2 update release.

q2cli version 2022.8.0
I recently updated qiime2 from version 2022.2 to 2022.8.
I updated q2studio as well to the latest version.
when I run npm start it shows the following error message:

npm start
npm ERR! Invalid version: "2022.8"
npm ERR! A complete log of this run can be found in:
npm ERR! /Users/alejandrotrujillo/.npm/_logs/2022-08-29T18_41_58_343Z-debug.log

I went back to the 2022.2 version and now it does not run q2studio anymore.

I natively installed qiime within a conda environment.
Currently running MacBook Pro (13 inch, M2, 2022)

Hi @otrujillor,

Welcome to the :qiime2: forum!

q2studio is not currently maintained by the QIIME 2 core development team at this time, and we will actually be depreciating it in our November software update. There may be some conflicting dependencies that are causing this issue within your QIIME 2 environment.

I'd recommend uninstalling q2studio first and then try re-activating your QIIME 2 environment to see if that resolves the issue. If it doesn't, I'd go ahead and delete this environment and just re-install QIIME 2 in a fresh environment, which should resolve the issue.

I'd recommend using q2cli (which already comes with any QIIME 2 installation) as your UI of choice, as opposed to q2studio. If you are looking for a GUI for running QIIME 2 commands, you can now use QIIME 2 within the Galaxy Toolshed!

Hope this helps!

Cheers :lizard:

Thank you so much, that solved the issue!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.