q2-picrust2 problem - nothing happened (even in tutorial)!

Hi everyone,
I’ve been working on my 16S rRNA microbiota data with qiime2-2019.4 with picrust2 plugin,
and I’m facing an unexpected problem.
Following the manual, I ran “qiime picrust2 full-pipeline” with input files, but nothing happened after few minutes. Literally, nothing happened: no error messages, no messages of success, and no log texts. it just got back to the terminal.
I also tested this plugin using tutorial data and scripts, but nothing happened as well.
This is my first time using picrust2 plugin, and I have been doing great with other qiime2 workflows. I could not get a result only in this plugin. What should I do in this situation? reinstall whole qiime2? or uninstall only picrust2 and install this again?

Thank you for reading =)

Hi @GoodKey,

I’m not the developer of that plugin, but to help them out, could you post the full command? It is strange that nothing happened, as QIIME 2 expects output and will raise its own error if it doesn’t get anything.

Are you certain that it had returned to the prompt? (allowing you to run other commands), or was it perhaps actually running (you can still type while that happens, just nothing will happen, at least no until it finishes)

Dear ebolyen,

Thank you for your answer, here is my full command:
$ qiime picrust2 full-pipeline --i-table table.qza --i-seq rep-seqs.qza --o-output-dir picrust2

In addition, I have tried this tutorial script with the example files in (https://github.com/picrust/picrust2/wiki/q2-picrust2-Tutorial):
$ qiime picrust2 full-pipeline --i-table mammal_biom.qza
–i-seq mammal_seqs.qza
–output-dir q2-picrust2_output
–p-threads 1
–p-hsp-method pic
–p-max-nsti 2

When I ran these commands, few minutes later, I got back to the prompt without any messages.

I agree that your mention “QIIME 2 expects output and will raise its own error if it doesn’t get anything” because I have been used qiime2 for months and other plugins have worked well (otherwise, it showed me an clear error message about what was the problem).

Thank you for your help =)

Hey @GoodKey,

I’m not sure what’s causing this issue, but the most likely problem is insufficient RAM (it should require about 16 GB of RAM to run the program). Could you try running the command with the “–verbose” option?



1 Like

Thank you, @gmdouglas.

I think you are right. The problem is related to insufficient RAM and with --verbose option, now it shows me the detailed processes of q2-picrust2.

Thank you for your advice!