q2-feature-classifier

Hello I was trying the feature-classifier command but it gave me this error:
command- qiime feature-classifier classify-sklearn --i-classifier silva-132-99-515-806-nb-classifier.qza --i-reads rep-seqs.qza --o-classification taxonomy.qza
Plugin error from feature-classifier:

The scikit-learn version (0.20.2) used to generate this artifact does not match the current version of scikit-learn installed (0.23.1). Please retrain your classifier for your current deployment to prevent data-corruption errors.

Hi @Saraswati_Awasthi,
Welcome to the forum!

This is actually a rather common error we see on the forum. If you were to search part of this message into the search bar you’ll see a series of similar answered questions.
In short though, as the message implies, there is a mismatch between the classifier’s scikit-learn version, and your current Q2 version. Your best option is to retrain your classifier using the most updated Q2 version you have installed.

Good luck!

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.