Problems with trimming Barcodes from paired-end files

Hello,
Im new at Qiime. Im trying to trim the Barcodes with cutadapt, so as it says i have to have a ‘MultiplexedPairedEndBarcodeInSequence’ type of qza file.
but when im trying to import the files and creating the right qza file with this code:
qiime tools import
–type MultiplexedPairedEndBarcodeInSequence
–source-format CasavaOneEightSingleLanePerSampleDirFmt
–input-path row_files
–output-path multiplexed-seqs.qza

im getting this error:
No transformation from <class ‘q2_types.per_sample_sequences._format.CasavaOneEightSingleLanePerSampleDirFmt’> to <class ‘q2_types.multiplexed_sequences._format.MultiplexedPairedEndBarcodeInSequenceDirFmt’>

thank you!

Hey there @Yos.Dos!

When you say:

are you talking about demultiplexing your multiplexed reads? If so, just drop the --source-format flag:

qiime tools import \
  --type MultiplexedPairedEndBarcodeInSequence \
  --input-path row_files \
  --output-path multiplexed-seqs.qza

If this isn't what you are trying to do, please provide some more details about these data. Thanks! :qiime2: :t_rex:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.