Problems importin with multiplex paired end data

I'm trying to import some 16S amplicon data with the EMP format. I can get the .gza data:
$ qiime tools import
--type EMPPairedEndSequences
--input-path SCCWRP1
--output-path SCCWRP1.qza

But when I try to check the quality:
$ qiime demux summarize
--i-data SCCWRP1.qza
--o-visualization SCCWRP1.qzv

I get the following error:
Plugin error from demux:

_ Argument to parameter 'data' is not a subtype of SampleData[JoinedSequencesWithQuality | PairedEndSequencesWithQuality | SequencesWithQuality]._

Debug info has been saved to /var/folders/fv/s7zh3xf10jl165fbknm9vjym0000gp/T/qiime2-q2cli-err-gvp2gr1r.log

I've tried several things after that. I saw that the files could be corrupted, so I downloaded them again, zip them using gzip, and try to import again with the same result. I also tried with a different set of data with no luck.

Then I've tried to uploaded using the manifest:
$ qiime tools import
--type 'SampleData[PairedEndSequencesWithQuality]'
--input-path manifest1.csv
--output-path SCCWRP1.qza
--source-format PairedEndFastqManifestPhred33

And this time it worked perfectly:

But the problem is that I have the barcodes sequences in a separate file, so I can not proceed from here.

I don't have any idea why the EMP protocol is not working for me. Do you have any suggestions??


I don't know if helps, but I was able to import the barcodes independently and it worked:
$ qiime tools import
--type 'SampleData[SequencesWithQuality]'
--input-path manifestb.csv
--output-path barcodes1.qza
--source-format SingleEndFastqManifestPhred33


Never mind. I realized that I should demultiplex my samples before generating the visualization.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.