Problem with importing data

Hi!

I`ve been having problems importin my data. I choose “Casava 1.8 paired-end demultiplexed fastq” to import data.

However, I got the error messageMissing one or more files for ç
CasavaOneEightSingleLanePerSampleDirFmt: ‘.+_.+_L[0-9][0-9][0-9]_R[12]_001\.fastq\.gz’

Could you help me please?

Hi @blues,
It sounds like your files may not be Casava 1.8 format. Could you please show some example file names (and does that error message specify which file is in the wrong format)?

You may also want to try importing as a manifest format. Those are flexible to file name format.

This is some example file names

and this is the error

thank you very much

@blues
Your filenames are missing lane # info. Easy fix (credit goes to @thermokarst for pointing this out):

Import as a CasavaOneEightLanelessPerSampleDirFmt format

qiime tools import \
  --type 'SampleData[SequencesWithQuality]' \
  --input-path casava-18-pe-demultiplexed \
  --input-format CasavaOneEightLanelessPerSampleDirFmt \
  --output-path demux-paired-end.qza

I hope that helps!

I have tried this
qiime tools import
--type 'SampleData[SequencesWithQuality]'
--input-path casava-18-paired-end-demultiplexed
--input-format CasavaOneEightLanelessPerSampleDirFmt
--output-path demux-paired-end.qza

but the error is similar

image

I see — your file names do not fit that format either. Use the manifest format that I linked to above. That format has no restrictions on filenames; however, it does require you to create a manifest file.

1 Like

Thank you very much

I have tried this (create manifest file) but I have this error
unexpected error has occurred: All paths provided in manifest must be absolute

What does it mean All paths provided in manifest must be absolute??

That means use absolute paths instead of relative paths, so use complete file paths instead of file names.

e.g., instead of the relative path:

my-cool-file.qza

Use the absolute path:

/home/user/bob/Desktop/my-cool-file.qza

Does that make sense?

Sorry I had an error, I was missing /
but now

An unexpected error has occurred:

‘ascii’ codec can’t decode byte 0xcf in position 7: ordinal not in range(128)

See above for debug info.

See above for debug info is:

File “/home/fito/anaconda3/envs/qiime2-2018.8/lib/python3.5/encodings/ascii.py”, line 26, in decode
return codecs.ascii_decode(input, self.errors)[0]

Hi @blues,
Please see this topic. Could you please provide the same information? (and try that fix if you have the same specs).

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.