Problem while converting biom file to OTU

I got this error when I tried to convert biom file to OTU. I didn’t have this issue while working with less samples but I increased the sample number and the issue arose. I used the following code:

biom convert -i samples_10000_frequency_filtered.biom -o samples_10000_frequency_filtered.txt --to-tsv

I attached a picture of the error I got. It says “OSError: [Errno 22} Invalid argument”.

Could you guys help me with this?

I’m not quite sure on this to be honest, but I’ll suggest a couple of things while we wait for more helpful advice.
Are you sure biom is installed in this environment? If you’re using biom packaged with QIIME 2 you’ll want to make sure you’ve activated that env first.
Which Q2 version is this?
What does conda list show?
In the event this is caused by a corrupt install a Q2 re-install may resolve this.

1 Like

Screen Shot 2020-05-31 at 12.06.55 AM
Yes, biom is installed in this environment and I activated the environment. It was working well before the point where I tried to convert the biom to OTU. It only showed error in that point. I attached the screenshot of the conda list display. Can there be other ways to fix the issue?
The version of Q2 I am using is 2019.10.0

I’m not sure, haven’t seen this before, but a few thoughts:

  • Try running without the comment at the end of the line, its possible that it is being interpreted by biom (which would be weird).
  • double check all of your filepaths - run ls -lah to get a detailed view of the files in your working directory - make sure the filename is spelled 100% the same

:qiime2:

2 Likes