Problem when running quality-filter q-score-joined on joined reads

Hi, good day!

I was trying to do sequence quality control on the joined reads (using q2-vsearch).
The QIIME2 version I’m using is 2019.10

Below is the script i use:
qiime quality-filter q-score-joined
–i-demux demux-joined.qza
–p-min-quality 20 \
–o-filtered-sequences demux-joined-filtered2.qza
–o-filter-stats demux-joined-filter-stats2.qza

These are the errors I received:
There were some problems with the command:
(1/3) Missing option “–o-filtered-sequences”. ("–output-dir" may also be
used)
(2/3) Missing option “–o-filter-stats”. ("–output-dir" may also be used)
(3/3) Got unexpected extra argument ( )
/var/spool/slurmd/job04754/slurm_script: line 22: --o-filtered-sequences: command not found

Can anyone point me in a right direction? Thank you in advance!

Good morning @pyee0417,

Welcome to the Qiime 2 forums! :qiime2:

I think I know how to solve this problem!

I noticed your command is across multiple lines.

qiime quality-filter q-score-joined
–i-demux demux-joined.qza
–p-min-quality 20 \
–o-filtered-sequences demux-joined-filtered2.qza
–o-filter-stats demux-joined-filter-stats2.qza

In linux, each command is run on one line, unless you use the \ backslash \ character to continue the same command to the next line. This should work:

qiime quality-filter q-score-joined \
--i-demux demux-joined.qza \
--p-min-quality 20 \
--o-filtered-sequences demux-joined-filtered2.qza \
--o-filter-stats demux-joined-filter-stats2.qza

Keep in touch!
Colin

Dear Colin, thank you for the reply!
I’ve edited the script and rerun.

qiime quality-filter q-score-joined
–i-demux demux-joined.qza
–p-min-quality 20 \
–o-filtered-sequences demux-joined-filtered2.qza
–o-filter-stats demux-joined-filter-stats2.qza

However, I still received the same errors:
There were some problems with the command:
(1/3) Missing option “–o-filtered-sequences”. ("–output-dir" may also be
used)
(2/3) Missing option “–o-filter-stats”. ("–output-dir" may also be used)
(3/3) Got unexpected extra argument ( )
/var/spool/slurmd/job04769/slurm_script: line 22: --o-filtered-sequences: command not found

I really would appreciate if anyone could help me. Thank you in advance!

1 Like

Hi @pyee0417, as @colinbrislawn mentioned above, this is a formatting issue. Please attach your full script and we can help point out specifically what is wrong (it looks like when you are copying-and-pasting to the forum we are losing some of your formatting). You can also send a screenshot, although the actual script is preferable.

Your command is close, but you are missing something!

Thank you for the reply!
I had actually edited my script with / at the end of every line except last line. However, they were missing every time i posted here.

Below are my script and screenshot of script (just in case there is any problem with the file, so I attached both):
qualityfilter2.txt (598 Bytes)

Thank you in advance!

Are there any spaces after the \ slashes \?

qiime quality-filter q-score-joined \ 
         Is there a space right here ^

Did you write that script yourself, or base if off another template script? If it’s a template, maybe the author of the template could help you troubleshoot this. I’m not sure how your SLURM queue is set up.

Colin

For your kind information, I scripted it based on the “sequence quality control” part in alternative methods of read-joining in QIIME 2 tutorial.

Thank you.

Excellent! The tutorials are a great place to start.

Are you copying those lines directly into a .sh script using a text editor like Nano or Vi, or are you writing these scripts in Word?

The reason that I ask is that I only found one extra space character in your file, but the error you originally posted still looks different than that file you posted. This makes me think some program you are using, like Word, is changing the formatting and introducing errors…

Any clues you can provide would be very helpful!

Here is the whitespace I found on the --p-min-quality line:

Colin