Problem loading dada2

Hello,
I am working through the Moving Pictures tutorial and cannot figure out how to work around the following error. I am working in a Linux 64-bit supercomputer.

When I get to the step that asks to run this:

qiime dada2 denoise-single
--i-demultiplexed-seqs demux.qza
--p-trim-left 0
--p-trunc-len 120
--o-representative-sequences rep-seqs-dada2.qza
--o-table table-dada2.qza

I receive the following error and error log (attached).

Plugin error from dada2:
An error was encountered while running DADA2 in R (return code 1), please inspect stdout and stderr to learn more.

I understand that Iranges needs to be updated, but I'm uncertain how to do that. When I go into R and try to install or update anything related to Bioconductor I run into issues. Any suggestions are appreciated!

If it helps, here is the R that my qiime environment uses:

which R
/work/03071/dietrich/miniconda2/envs/qiime2-2017.12/bin/R

error_log_dada2_moving_pictures.txt (2.4 KB)

Hi, I actually solved this problem right after posting (of course). My qiime was using an R outside of the environment even though ‘which R’ stated that it wasn’t. I changed my .Rprofile so that it would use the R within the environment and everything worked after that.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.