Problem in runing qiime2 script

Dear All
I installed qiime2 two and and went through the tutorial commands and all went well. Later I combined all command in bash script similar to the one I used in qiime one but I found the following error message

"import_data
/usr/local/bin/qiime2_script_test.sh: line 12: qiime: command not found"

when I run the comamand directly in the terminal

# import data
echo "import_data"
qiime tools import \
  --type EMPSingleEndSequences \
  --input-path emp-single-end-sequences \
  --output-path emp-single-end-sequences.qza

It worked fine

Can any one help to fix this problem
Best regarsd
Adly

1 Like

Hello Adly,

There are several ways to fix this, but the root cause is that your terminal has the qiime conda environment activated (so it can see qiime), but the script does not have the conda environment activate (so it’s can’t see qiime and throws this error).

To fix this, you could try including the source activate qiime command inside your script. Are you running this on a server or cluster using a queueing system? Different systems set up environments different ways…

Colin

3 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.