Problem Importing raw files

Hi,

I have been having problems importing raw fastq files. Please find attached pictures of the errors I get.One of the pictures contain the raw files and the other the code I used.Capture Capture2

Hello @oast, an EMPSingleEndSequences artifact requires an input directory with exactly two files in it. Those files are sequences.fastq.gz and barcodes.fastq.gz. They must have exactly those names.

Please see the directions here for reference, and let me know if you require further assistance.

Thank you.

Yes, I understand this. But when I unzip the raw data file. These are the filenames it brings out.

There are two immediate options that come to mind depending on what you intend to do with this data further down the line. You can

  1. Split each set of barcode and sequence files into seperate directories and import each directory individually

Or

  1. Combine all sequences into a single sequences.fastq.gz and all barcodes into a barcodes.fastq.gz then import this single large artifact with all of your data.

Presumably you intend to demulitplex this data after importing it? If so, do you have the necessary metadata? The structure of the metadata, along with what you want to with the data after importing it, may help in determining which path forward is better.

I have tried option 1 and still get the same error. I have the metadata

Can I see an example of one of the directories you spit the data into

EDIT: Additionally, have your reads already been demuxed?

They have not been demuxed. I am just trying to import them first before demultiplexing.
Find attached the example of directory i split the data into.

I had been proceeding under the assumption they weren’t demuxed, but thought I should make sure. The files in your directory must be named exactly sequences.fastq.gz and barcodes.fastq.gz in order to be imported as EMPSingleEndSequences. There can’t be anything else in the file names. If you change the names to exactly those I believe the import will work.

I changed the names since the raw files did not come in exactly that name but I still get the same error.
Find attached the picture and steps I took.

You need to change 170_s_1_1_withindex_sequence_barcodes.fastq.gz to just barcodes.fastq.gz and 170_s_1_1_withindex_sequences.fastq.gz to just sequences.fastq.gz. Apologies for not being more explicit before.

I changed the names and import of files worked. However, I encountered this error while demultiplexing.
Find attached.Capture (1)

Now that you can import, please create a new forum thread about your demux related issues and I’ll help you with those in that thread. We prefer to keep all threads to one specific topic. Please include the following in the new thread.

  1. The directory you are trying to import
  2. The command you are using to import
  3. Any information about the environment you are using (is this a native install, a virtual machine, an hpc, what os and version of said os are you using, etc.)

Thank you.

1 Like